Brave 1. 51.118 on Ubuntu 22.04.1

The browser no longer renders pages correctly. The pages continuously flash. And some pictures are not shown

This happens in normal start-up. And all the time.

Ubuntu 22.04.1 Brave Version 1. 51.118

Other browsers such as Edge are working with no issues.
It works in Incognito mode, but then menus are not rendered correctly.


Have the same issue. It could be related to Mesa drivers that was updated on Linux yesterday. Yesterday all worked fine, today after mesa driver update Brave is not rendering correctly

1 Like

Disabling hardware acceleration resolves the issue. Settings → System → Use hardware acceleration to OFF.

what do you do if the settings page doesn’t render either?
Running Brave from the terminal with brave-browser --disable-gpu doesn’t solve the issue.

Go to your settings file (located in: ~/.config/BraveSoftware/Brave-Browser/Local\ State) - it is a JSON file. Find the setting for acceleration (“hardware_acceleration_mode”) and change it manually. Relaunch. I guess that should help.

I just put this into a new tab brave://settings/system and deselected use hardware acceleration when available.

Restarted and all OK now. Editing the JSON file did not work for me.

None of the proposed solutions work for me. Manually adjusting the hardware rendering in Local State does not seem to have an effect, and the settings tab is unreadable.

Brave Version 1.51.118 Chromium: 113.0.5672.126 (Official Build) (64-bit)

Kernel: 5.19.0-42-generic x86_64 bits: 64 compiler: N/A Desktop: Cinnamon 5.6.8 tk: GTK 3.24.33
wm: muffin dm: LightDM Distro: Linux Mint 21.1 Vera base: Ubuntu 22.04 jammy

In my case, the settings page does not render either, so it’s impossible to deselect a checkbox.

Editing the settings JSON file does not fix the issue either.

Neither does starting brave with --disable-gpu option

I have the same issue. Disabling hardware accelaration works. or launching it with brave-browser --disable-gpu but this issue should be fixed. Disabling gpu is a band aid solution

Deleting the GPUCache directory, as described in this issue, solved the problem for me Latest Brave Update fails to render any webpage correctly - #4 by grey-owl

1 Like

Then try this:

Empty the GPUCache folder inside your Brave profile default folder. That should work if all other options fail.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.