Brave linux does not render properly

Since yesterday after a reset, my brave browser does not show almost any images, it doesn’t matter which page, even in settings, rewards, developer tools is making weird things. I tried restarting the computer and I got the same issue time after time, that make the browser completely useless.

Some cases images are not shown, and other specially with popups, other tabs are showing instead of popups and popups are flickering. I post some example images.

I read online and tried clearing browser data, and cached images, but the problem still exists.

How can this issue be reproduced?
No idea

Expected result:

Brave Version( check About Brave):
Version 1.52.130 Chromium: 114.0.5735.198 (Official Build) (64-bit)

Additional Information: I tried Firefox and Chrome in the same machine and brave in a windows machine, and works fine, so nothing related.

1 Like

I experienced a similar problem where google maps didn’t render properly.

However, after disabling the “Use hardware acceleration when available” in the systems setting, it worked fine again.

I’m using LinuxMint 21.1 with Latest Nvidia 525 driver and Brave Version 1.52.130 Chromium: 114.0.5735.198 (Official Build) (64-bit)

I really don’t know. I installed a nightly version of brave, and worked fine, chrome too, I saved al my open tabs (it was a lot) and was in the mood to uninstall it or something, I close it and open a new one and worked again, and for now, no more issues.

I tried yesterday the same and it didn’t work. I found other people with same issue in Reddit and also for chrome, so maybe is kind a bug, not sure.

I can also confirm that I have the same issue on Linux MATE 22.04.2 LTS (Jammy Jellyfish) 64-bit.
When disable hardware acceleration if works fine again. I never experienced similar issue until today.

I have the same issue :frowning:

facing same issue here
Brave Browser
Ubuntu: 22.04.2 LTS (Jammy Jellyfish) -Chromium: 114.0.5735.198 (Official Build) (64-bit)

UPDATE: I managed here, just disabled GPU, running the command below, then in Settings/System I disabled > Use hardware acceleration when available

/usr/bin/brave-browser-stable --disable-gpu

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.