Brave 0.70.80 crashing after 2 minutes

Description of the issue:
Brave suddenly closes without any warning after 2 minutes of being open. No crash notice for the executable in Event Viewer. brave://crashes shows the following (I’ve been trying to isolate the issue, so lots of crashes :slight_smile:). Disabling all extensions changed nothing. Even having it just at the New Tab page and doing nothing else it still crashes.

Steps to Reproduce (add as many as necessary):

  1. Open Brave
  2. Do literally anything (or nothing at all!)
  3. Browser disappears
  4. Reopen browser, and are prompted to reopen tabs

Actual Result:
Browser disappears (crashes) without warning, nor message. Does so repeatably after 2 minutes.

Expected Result:
Browser should stay open until instructed to close

Reproduces how often:
Always

Brave Version:
Brave 0.70.80 Chromium: 76.0.3809.132 (Official Build) dev (64-bit)

Additional information:
Occurs on my desktop: Windows 10 Version 1903 x64 Insider Build 18970.1005)
…and a Surface Pro 4 of the same OS version as above.

Hi, @WebAsh. I’m thinking this is a Windows Insider Build issue since my non-Insider Windows 10 OS Version 1903 (Build 18362.295) runs the same version of Brave without issue. Or maybe it’s an extension that’s not playing nice in that environment. Do you have any extensions installed (Brave Dev does not)?

@Mattches can you provide any insight on this?

Hey mate thanks for the reply! If it was a Windows build issue I’d expect there to be log entries in Event Viewer. But nothing shows. Other chromium based browsers (Edge) don’t appear to be having issues.

I’ve tried disabling all extensions and it still occurs.

It’s driving me insane. At least if an error message showed somewhere I’d have an avenue to look.

I’m new to assisting with Brave dev builds: is there a way to access the crash logs and see what component fails?

@WebAsh,
Dev build crashes are to be expected. I would suggest try disable Hardware Acceleration in settings to see if this has any effect.

Settings --> Additional Settings --> System --> Hardware Acceleration

1 Like

Unfortunately same occurs even after disabling Hardware Acceleration.

1 Like

@WebAsh,
Is your device connected to/part of a Sync chain by chance?

1 Like

Aha! I do indeed. Is that kicking off after 2min and that’s causing the crash?

Hi here the same issue, but running at Mac.

My Brave Dev (v 0.70.80) was part of a sync chain and crashed continuously!!! I left the sync chain and now it runs stable :slight_smile:

Curious. I can’t recall the exact moment it started happening but it might coincide with the last mobile device I added. I’ll try removing that device and see if it goes back to normal.

Nope. Removing the last added device to the chain didn’t fix it. I can confirm that Brave is crashing on all Windows machines in the same chain, regardless of whether they are an Insider build or not. Is there a known issue with Sync that is causing this? @Mattches

I had the sudden idea of testing a Brave Dev profile which didn’t have a sync chain in it. That one also crashes after 2 minutes. So either the default profile is still running while the other profile is, OR the crash is not related to the sync chain.

Even if it was the sync chain, why is Brave crashing in one profile able to take out another profile?

@WebAsh,
That’s very strange.
Would you mind testing against a different Brave installation to see if the browser crashes the same way as it does in Dev? Simply download and install Brave Beta channel or Release channel on your PC, open it up and see if you get the same behavior.

Note that all Brave installs will run parallel to one another, so installing Release/Beta won’t overwrite or interfere with any data you currently have in the installed Dev version.

Let me know what you find out.

I have the same issue. Just crashes after 2 minutes, always. Disabled extensions, disabled HW Accel…nothing helped.

Brave Beta channel and Release channel work normally without crashing.

Are you still having the issue? I began having this issue a few days ago, but Version 0.70.93 fixed it for me. I’m trying to aggregate some information here:

I’m on version 0.71.72 and its still happening. My behaviour is after 2 minutes, rather than ~20 seconds; but perhaps Windows doesn’t attempt a sync as quickly as the Linux version?

Do you mean to attempt this with or without a Sync chain? I’ll load up the Beta channel now standalone and see how I get on.

As I stated earlier, the sync chain seems the problem. After leaving the sync chain Brave runs stable again.

1 Like

No issues on the Beta channel. Really converging on the issue being related to:

  • Dev
  • Sync chain
1 Like

Thanks for the information everyone. I’ll be forwarding all info in this thread to the devs – will leave this thread open for now as well incase more information comes to light or the devs have a solution/test to try.

1 Like