Both brave wallet and trezor connect pages hang indefinitely when trying to connect a trezor for the first time

Description of the issue:

  • new user
  • On brave://wallet/
  • Trezor device is recognized
  • click “Connect” and both the brave://wallet/ and hang indefinitely. I tried to figure out how to ‘block popups’ on Brave, but no avail.
    –> unable to connect wallet

How can this issue be reproduced?

  1. try to connect a new wallet to a fresh/new user on Linux Ubuntu 18.04

Expected result:

Connect wallet

Brave Version( check About Brave):

Version 1.9.76 Chromium: 81.0.4044.138 (Official Build) (64-bit)

Additional Information:

1 Like

Brave wallet can only be connected to a Uphold currently

Same bug here. The behavior is identical with Metamask.
I’ve whitelisted [*.] along with, same result.

any news about this problem? thanks

1 Like

Good news everyone! I’ve upgraded to Metamask 8.0.3 from and this fixes the issue for both Metamask and Brave’s integrated wallet.

1 Like

I had the same problem today with Metamask 8.0.5. Fixed by installing developer version 8.0.6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.