Bookmark Manager Automatically Scrolling To The Top Of The Page

I have bookmarks within folders and sometimes a folder or two WITHIN a folder.

On my bookmarks bar is a folder icon. Within that folder are MOST of my bookmarks. Some of them are folders. When I open one of those folders there are many links. This way I quickly find what I seek and click the link.

Now, If the bookmark manager is opened (instead of using drop down menus) it opens in its own browser page. That page shows bookmarks and folders. At the end of each line on the right side of the page are three vertical dots that indicate more choices.

If I open a folder on that page, the window changes to show the contents of that folder exactly the same way as the original bookmark manager page. Each link has the same three vertical dots indicating more choices. In this folder are MANY bookmarks. If I scroll down and stop to look at what is there, within ten to thirty seconds the entire page will automatically scroll to the top of the bookmarks list. It’s like trying to read a long article on a page and the browser keeps scrolling to the top of the article every few seconds. I HATE THIS!

This happens on my Chromebook w/Linux AND my POP!_OS GNU/Linux laptop. I don’t have any Windoz or crApple Machines. I previously reported that this behavior wasn’t happening on the Linux machine. That was incorrect. I have since found why the scrolling didn’t happen. Here it is.

If the bookmark manager is opened. Then a folder is opened and the bookmarks are shown, the automatic scrolling will happen if I’m looking at bookmarks far down the list. The way the scrolling will stop, is if any bookmark is clicked and that causes it to be highlighted. Any highlighted bookmark will prevent the automatic scrolling. Now that I know this, the problem is ameliorated, but it isn’t fixed.

The page should not be automatically scrolling upward.

I have found that on my computer, the initial page of the bookmark manager WILL NOT automatically scroll up if I am viewing the last of the bookmarks. Even if the page had to be scrolled down to get there. The automatic scrolling to the top of the bookmarks always happens inside an open folder on the bookmark manager.

Try it with one folder and then a folder within a folder. You will need enough bookmarks within the folders to make scrolling necessary.

In my experiments, the symptom of automatic scrolling to the top will stop after a few tries. This was in a folder within a folder. It was found that if I clicked up one folder and then up another folder to the opening page of the bookmark manager, then returned to the folder in a folder and scrolled down, the automatic scrolling will start again. This is a folder with at least one-hundred links. I don’t know if that is a factor. Please repair this bug.

Thank you for making the Brave browser and doing what you can to keep us safe.


Version 1.45.133 Chromium: 107.0.5304.141 (Official Build) unknown (64-bit)

2 Likes

Hello there @Smallwheels please accept my apologies for this inconvenience. Does disabling Hardware Acceleration in settings prevents this issue from happening?

You’ll find this in Settings --> Additional Settings --> System --> Hardware Acceleration

Let me know if that works.