Bitchute is broken on Brave

Any attempt to navigate on the Bitchute page is met with the sites: “An error has occurred whilst processing your request!”

Now I thought this was an issue with Bitchute due to the nature of the message, such as my account being deleted. Nope, tried others and they also failed. Then I tried the same accounts in other browsers and they worked. Then I found that Brave in tor and private mode worked perfectly fine too.

So something is up with Brave not wanting Bitchute to work in it’s normal state, and emailing Bitchute support about the issue didn’t go anywhere as they don’t respond.

Tried varied combinations of shields, add, cookie, and fingerprinting controls and they didn’t have any effect.

Also “Brave is up to date
Version 0.65.121 Chromium: 75.0.3770.100 (Official Build) (64-bit)”

Exact URL:

Any help on this would be greatly appreciated as I see many recommending both Brave and Bitchute together but they both fail when together in my case. Thanks.

Does disabling sheilds help?


Is this only when you are signed in to your Bitchute account?
Can you nagivate on Bitchute when you are NOT signed in? :thinking:

What system and device are you using?


I have the same issue since maybe a week or two and recently I realized that it doesn’t happen on chromium, only on Brave. Regardless if logged in or not.
Let me specify the issue. When on Bitchute, any video clicked directly will throw the above error. But when opened in a new tab (via ctrl+click or middle-click) it opens just fine. That’s how Im watching all my videos now, lol. Btw Im also on linux mint 19.1 cinnamon, not sure if that plays a role.
Thank you for your time.

Just thought I’d chime in. I had the same problem, it turned out to be the refering URL was blocked between page requests by PIA VPN.

So, if you’re using a VPN or any additinal privacy extensions alongside bitchute, you may need to check their settings - in the case of PIA, you can easily turn the referer back on - although unfortunately not just for bitchute alone - sadly it’s just a block all or nothing setting.

If http referer is disabled, then URLs on bitchute will appear to be broken - it seems Bitchute looks for a referring URL, and if it can’t find one, then it throws the error.

If you’re wondering what a HTTP Referer is, it’s basically the URL of the page that referred you to the page you are visiting. In terms of privacy, if it is disabled the domain you are visiting won’t be able to see which page or domain you came from. Ideally for bitchute to remain compatible with certain privacy extensions & VPNs, this is an issue that Bitchute would need to fix at their end.

Than you for the reply.
Unfortunately I’m not using a VPN :confused: I tried also to clear the cookie data for the site, without a change. It remains a mystery. I hope it will get fixed with time if more people have this issue. As I said, on chromium it is just fine.

Does browsing in private mode / sheilds disabled help?

As the original message from Jezza said, without shields (turned off) nothing changes. But in a “New incognito window” ctrl+shift+N it works! Hmmm… Can this be fixed also in normal mode? Thank you.

This could indicate it has something to do with some stored cookies/website data.

While on Bitchute, try this:
Click on the lock symbol in the navigation bar, then on “Site settings”.
In the window that opens, click “Clear data” and “Reset permissions”.
Does it work now? (You might need to disable the shield again)
If it doesn’t, consider deleting all “Cookies and other site data” here: chrome://settings/clearBrowserData
Make sure “Time range” is set to “All time”. (Note: this will log you out of all websites)
Does it work for you now?

I just tested clearing all cookies for the site again. After that it was fixed, but only as long as I didn’t log in again. After the next login and new cookies, it was again the same.
I will try the same again with disabled shields during the whole process. If that also doesn’t help, Im still reluctant to clear all my logins from all sites, but I might have to.
Thank you very much for your help.

If it worked once with cleared cookies, that sounds good! Disabling the shields on that site directly after clearing the cookies might be working then.

Wau! It’s fixed! Now it seems permanently.
So I disabled the shields, cleared the cookies, restarted browser, logged in - and it works. I reenabled shields, restarted again and it still works.

I have 2 theories why that is.

  1. It seems that the cookie creation with shields up for this site was a problem.
  2. This time I deleted the cookies via “lock icon” - “cookies” - 2x remove… Instead as previously “lock icon” - “site settings” - “clear data”…
    I also noticed that this time I lost the dark theme for the first time, so… maybe the previous “clear data” process didn’t clear the cookies fully.

Either way, thank you very much for the help <3

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.