BAT disappeared after a wallet recovery

Hi! I’ve installed Brave Browser today. But I already had a Brave Rewards wallet last year. So I restored this old wallet with the recovery phrase. After this step, brave rewards showed that I had to claim 1 BAT from previous Brave-ads. What I did. My BRAVE wallet showed me 1.0 BAT. But after closing and reopening the wallet, I end up with 0 BAT. I know this is only 1 BAT but it’s weird and still an issue.


I have exactly the same problem. If I restore my wallet with the recovery phrase the account balance says 0, but the pending reward is listed. I tried to recover it on different computers, but the result is always the same.


I have the same problem

Is there anything we can do on our side?

I would highly appreciate an answer from support. Thanks.

Why is there no support for us?

I had to restore with my seed as well. All gone. It wasn’t much, so I don’t care about the “loss”. But today I’ll stop using Brave browser.

I liked the idea of Brave Rewards. It would bring back sane Ads like in the internet of the 90s and helps mass adoption of Crypto Currency.

Oh boy was I wrong. This is a shame!

I’m in crypto for a long time and I used and tested many wallets for many coins as well as multi coin wallets. The Recovery seed always worked on all of them. Why is that? Because that is one of the most important feature and every sane developer knows that this has to be tested thoroughly for every single release. And with thoroughly I mean something like this: Create multiple/many seeds with every old release and restore with the latest release.
And there’s no “but” here. If it takes a whole day, test it! If it takes a whole week, test it! If it takes a whole month, test it! No excuses!

You can’t be a big player in Crypto Currencies if your recovery seed recovers nothing!

I’m so glad I noticed this problem before suggesting Brave to friends and family.

EDIT: OMG! I just discoverd it. Not only this doesn’t work, it’s meant to not work like. What a fail.

1 Like

I have no interest or stake in this issue, But I want to keep this thread going just to see if support ever responds - I have my doubts. I suggest others do the same. It appears that this company is not what it hopes to portray itself as in the public eye. Anyone have suggestions for true privacy browser alternatives.

Wouldn’t it be nice to actually find a company that DOESN’T bait and switch, or bait and take away as it were?

Same issue here, seems like everything that should sync/remember doesn’t work in Brave. No bookmarks, no password and also the Brave rewards backup/restore function is broken.

After a long time of testing, trying to debug I give up. Back to FireFox or Chromium.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.