Bank of America Website won't load

Description of the issue: When I try to connect to Bank of America website, says “Site Can’t be reached”, connection times out. Address bar shows that site is not secure. Never had this problem before, I log into BofA website daily. Started yesterday.
How can this issue be reproduced? Every time I log into BofA website.

Expected result:

Brave Version( check About Brave): [Version 1.0.1 Chromium: 78.0.3904.108 (Official Build) (64-bit)]
Additional Information:
Tried to delete history/cookies. Turn off shields. Can’t get it to load. Other bank website like and I can access like before.

hrmmm… I just did some banking in bofa about a week and a half ago… have you tried to access on a private window? Initially I would think maybe a misbehaving extension… but hard to say…

Edit: made screen cap…

Thanks @megaspaz for confirming. Can you re-test @DeeMan ? Does it work in private mode? Also clearing cookies may help.

Thanks for the suggestions and willingness to help me. Turns out that the Bank of America website and their mobile application were all offline yesterday so this had nothing to do with Brave. I discovered this a every browser was having the same connectivity issues.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.