Autofill does not fill fields without clicking first

Description of the issue:

Brave requires user interaction to select a login from the saved logins stored by the password manager when attempting to login to a website via autofill, despite having specific options disabled to prohibit the behavior.

How can this issue be reproduced?

  1. Set Brave autofill settings and password manager to enabled.
  2. Disable [#fill-on-account-select] and [#fill-on-account-select-http] in the brave://flags page and restart the browser.
  3. Navigate to a web page with a saved password in Brave’s password manager and let the browser autofill the login credentials without clicking on the form field first.

Expected result: Brave should autofill the saved login credentials of a given web page without any further user interaction, but still requires a click on the form field and selecting the saved login for that particular page.

Brave Version: 1.1.20

Additional Information:

I have a 2018 Mac Mini running macOS Catalina 10.15.1 with a Brave Browser running version 1.1.20. I have an issue that has been discussed about in these forums before, but the posed solutions do not appear to remedy the situation.

The problem is that when Brave is set to save and autofill passwords, the login page of any website does not fill automatically with the login information saved by Brave unless the form field is selected, and then the saved login is clicked. I simply wish to save this step and have the form fields filled automatically on page load.

This change from the old autofill method is due to security issues, which other Brave community members have kindly explained and linked an article on the subject as well, so I do understand that. Unfortunately, the proposed issue, which is to navigate the Brave browser to the brave://flags page, and then disable both the [#fill-on-account-select] and [#fill-on-account-select-http] options, and finally restart Brave do not seem to help. I have also checked to make sure there is no third party password manager that might be overriding the built-in Brave password manager.

Is there another option to disable in the brave://flags page, or another method I can try to resolve this issue? If there has been a post announcing how a newer update has rendered the brave://flags approach moot, I apologize in advance for missing it.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.