Autocomplete suggestions for address bar not working for bookmarks

Description of the issue: In the browser settings, “Show autocomplete suggestions in address bar” setting it to something like browsing history works as expected. As you type a URL/search it populates suggestions and has the most relevant one at the top, letting you hit enter to auto-complete it instead of typing the whole thing out or using arrow keys to select it. However when setting it to just bookmarks, the bookmark result(s) are always at the bottom, even if bookmarks is the only toggle enabled. This requires arrow keying down every time instead of a quick enter to select.

How can this issue be reproduced?

  1. In settings enable “Show autocomplete suggestions in address bar”, and in the new selections only tick “Bookmarks”
  2. Start to type something that you have bookmarked, like
  3. Be upset when the bookmark result is inconveniently placed at the bottom.

Expected result: When I type something like “youtube.” the bookmarked page “” should be in the address bar and selectable with just the enter key.

Brave Version( check About Brave): Version 1.45.88 Chromium: 106.0.5249.91 (Official Build) beta (64-bit)

Additional Information: None.

1 Like

I’d like to add here that bookmark suggestion tool won’t suggest all the relevant bookmarks, while other competitors show all the bookmarks.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.