App stopped working when trying to access passwords

Troubleshooting technical issues is much easier when both the user and support agent practice clear communication. For this reason, we have provided the template below for you to fill out with information about your issue. Please provide as much detail as possible so we can most efficiently resolve your problem.


I use Brave on both my laptop and on my Samsung Galaxy Note 20 Ultra 5G. Last night, my phone received an update from Android 12 to Android 13 as well as Samsung"s UI from 4 to 5. there have been a few glitches. Although not related to Brave, I was initially having problems accessing Samsung Pass which is a password saver for the phone. At the same time, I began having problems with Brave passwords. The issue is that when I open Brave browser, go to Settings, and then down to the General section, I see the Passwords choice. I click on it and there I see the list of sites and user names for all the sites I have saved passwords in Brave. When I click on a specific one, the screen flashes for a second and then Im back to the Settings page. There I will click on Passwords again and once again see the list. I click on a random site and user and end up back on the Settings page. If I do this several times, I get notification that Brave keeps stopping and Brave will close on me.

When I go to a site that a password had been saved on, I do get a popup and can click on it and then the password saved in Brave will auto fill the user name and password. So I know that the passwords are there. There are just times where I need to view the actual password for a site and that wont work.

On my laptop using Brave, I can get into autofill, the passwords and view all the passwords for the saved sites. However that would be a bit of a problem as I obviously dont always have my laptop with me.

What I have tried… Tried force stopping Brave in Android Apps and restarting.

Tried force stopping and deleting cache.

Tried restarting phone and then entering the Android Recovery to wipe the cache and repair apps and letting phone restart.

Tried deleting Brave from phone and removing the phone from sync chain using Brave on the laptop, reinstalled Brave from Google Play on phone, added phone to sync chain and letting all the content sync. Everything showed back up but still cant get passwords for the saved sites.

And this is recent. Before the big phone update, I know that this was working as recently as yesterday. And although not Brave related, I did finally get Samsung Pass working by deleting Samsung Wallet, force stopping in Apps, deleting cache and then data, then restarting Samsung Pass. It then restored all those saved passwords along with having me install Samsung Wallet. It finally worked after this so that part is fixed. Just not sure if its related to Brave or if the big update caused some kind of problem.

Brave Version( check About Brave):
1.45.127, Chromium

Mobile Device details
Samsung Galaxy Note 20 Ultra 5G
Android 13
Samsung UI 5

1 Like

Hello there @mikeyk101 please accept my apologies for this inconvenience. Could you please try installing the Beta or Nightly version of the Brave app on your device to see if the issue persist?

Be waiting for your response.
Regards.

I installed both the Beta and Nightly version temporarily and got the same results. I synced them to the chain to get all the bookmarks and passwords loaded. The passwords list shows up in Beta and Nightly just like the regular version and when I tap on any of the listed sites, Brave closes and restarts right away.

Surprisingly, everything else about saved passwords still works just fine. If I go to a site where the user and password is setup, it will fill the boxes just fine. If I go to a new site and create an account, I get asked if I want to save it and it will.

But like I mentioned, it is a pain because there are times I may need to view the password after going into settings and I cant. And I just realized another issue that comes as a result of this, I can no longer manage/delete sites and password data if I wanted. This is only on my mobile version. If I really needed to, I could always fire up Brave on my laptop and manage the password list that way but if Im out and about and dont have access to my laptop, Im stuck.

So it kind of works, just dont have full capabilities.

I dont think its a problem with the phone software. I have the Samsung internet browser and that uses Samsung Pass to save passwords and that works. I also have Firefox and can access passwords there. Same with Google Chrome. I do use Brave exclussively though, I just have the others as a backup in case I run into a problem with a particular site using Brave. That doesnt happen too often but has popped up before.

1 Like

@mikeyk101 would you be able to enable crash reports in Settings->Brave Shields & privacy->Automatically send diagnostic reports? After that make it crash and open brave://crashes and provide us with an Uploaded crash report ID. Thanks.

1 Like

Here is the id’s from today:

e4500100-1c77-3409-0000-000000000000

3 Likes

Another thing I have noticed that Im not sure if its related… Sometimes if I have left the Brave browser open on some random page and went to open other apps then come back to Brave, it will be back on the Brave home page and whatever page I had been on is gone. This means that Brave had crashed again and then reopened on the home page automatically.

Along with this, in Android settings under default apps, I select to have Brave as my default browser. It seems like after several Brave crashes, the settings will show the browser is not set. I can reselect Brave and it will stay set for a bit but I think after Brave crashes again several times, the default browser selection reverts back to not set.

2 Likes

not sure if it’s related but I am having major issues on Android (4 different phones tried) logging in to, say, ebay or gumtree…I start typing the username and the page freezes, I can move the (Samsung default) keyboard and I can see what I am typing on it but it doesnt go into the login box, likewise if I try to use Bitwarden, nothing happens.
I am sure it was also a problem yesterday on my Windows 10 laptop where “the page has timed out” message appeared but today that seems to work

I tried un-installing and loading a previous version which had the same problem

related ?

1 Like

I have the same issue. The app crashes everytime I try open a saved password in the passwords menu. I have reinstalled the app and everything but the issue still persists.

Samsung Galaxy s21 with the newest android 13 OneUi 5

1 Like

And now a new glitch. Kind of related to what the others are mentioning about entering text from keyboard. On several forums, when I select reply, it will initially work fine. But as I add more text, I will sometimes get freezes where I cant add any more text, or suddenly the text will scroll up fast by itself like as if I hit the down key until I see a blank space in the reply box. I can use the back/delete key to usually get all the way back to the text I was working on but it takes a while or it doesnt work at all. I sometimes have to close Brave, reopen it, and go back to the thread I was replying to. Then I can usually start typing text again for a bit. As long as I dont need to add too much more to my reply, I can finish it. Not always though…

And this really popped up after I did the update for Brave from Google Play yesterday. The other problems are still present even with the update. I did experience the “reply” issue before but it was quite some time ago but got resolved Im assuming by an update.

2 Likes

Well I partially solved one of my problems. I just installed a different keyboard from Google Play and am now using it instead of the Samsung keyboard. My “dissappearing” text no longer seems to be a problem.

2 Likes

Hi again @mikeyk101 do you have power saving mode enabled on your device? If that’s the case, please try disabling it to see if the application no longer crashes when opening the password manager.

Regards

1 Like

Power saving is off and always has been.

2 Likes

@mikeyk101 @91a51ebc214ea7d43e7e do you by chance have some custom font on your devices or is it a stock default font? I see from the crash stack @mikeyk101 provided above that it crashes somewhere in the OS on making manipulations with a font.

1 Like

I just took a look in the phone settings under display and then fonts. I had never really played with that. There are 3 choices, default, SamsungOne, and Gothic Bold. It was selected for Gothic Bold which it must have been since I first started using this phone about a year ago. I just switched it to default and will try that and see. The only thing I have done since the issue popped up was to install another keyboard because the stock Samsung keyboard had become glitchy like I mentioned above and almost unusable in many forums. But this new key board comes with its own set of glitches especially with the spacebar. It will think I pressed the “b” or “n” key instead of space bar causing me to constantly backtrack and remove the extra letters. But at least it won’t suddenly scroll down in reply and makenit hard getting back to the body of the reply.

So I will try default font and stock keyboard again and report back.

1 Like

I did a quick close of Brave completely and reopened it. I went to settings and then passwords. I clicked on random entry and still no access to the passwords. Screen flashes and goes right back to password listings without opening the specific password entry…

1 Like

I have selected SamsungOne font, with bold text.

1 Like

Did that fix your issue? Or are you just saying how yours is set and you dont have issue anymore?

1 Like

Oops, I see that you were just replying to Serg

1 Like

Yeah I still have the issue :confused:

1 Like

@mikeyk101 @91a51ebc214ea7d43e7e do you have any possibility to try it out in Chrome? Just to help us know is it upstream bug or Brave’s specific only.

1 Like