Google login button can't be disabled

I disable Google login buttons, but it appears on webpages and when I click on it, it opens Google login page.
OS: Xubuntu 20.04
Brave version: [Version 1.32.113 Chromium: 96.0.4664.45 (Official Build) (64-bit)]

How is the Google login button disabled? @kadir

In settings there is Social media blocking option. I disabled Google login button in that page.

It’ll break google logins, but not entirely stop the buttons from showing. Could add Fanboy Annoyances or Social in brave://adblock to help with many of the social buttons here also

I have just tried to signup and signin Twitter and Ted with Google account in private windows, it works but at the another webpage it doesn’t work. Also sometimes I see accounts.google.com link at the left bottom of the screen while loading the pages. I just wanted to report bug if it is a bug.

No bug I’m aware of. If you view the google login popup on nytimes.com for example, this is stopped, if you change your social settings in brave://settings