Android ads not showing

Haven’t received ads on my phone for a couple months

What Operating System and Brave version are you using (Menu --> About Brave)?
1.38.109
Is your browser wallet currently verified? (yes/no)
Yes
What date did you verify your wallet?
2021
Have you been able to successfully receive payments in the past?
Yes
Are you using a VPN? (yes/no)
No
Are you in a supported region (see here for list of supported regions)?
Yes
Does your device pass the SafteyNet check (Android only)?
Yes
Have you manually turned off Auto-contribute on all of your devices linked to Uphold??
Yes

I have it set to 10 ads per hour and turned on the ads when brave isn’t in use but it hasn’t shown anything for ages

Hi, have you checked the Regional Catalog Viewer to see if there are ads available for your region?

I’m curious if you are getting any error messages? Payment processing appears to be working as normal?

With all the payout issues, Brave did disable ads (a couple of times I think) for a while because of issues but I think everything is back to normal… have you tried clearing history/cache, exiting the browser, and reopening? That works for some users.

That’s all I can think of at the moment. Please post an update! Hopefully you have already started receiving ads again!

im in the USA so theres certainly no shortage of ads. I get plenty on my desktop but not one on my phone in the last few months. Ive definitely cleared my cache and reopened plenty since it stopped working. Still nothing sadly. I should add that the lever to turn on brave ads glitches into the off position and takes several tries to get it to stay on. The uphold wallet balance it shows on my phone is 10BAT less than the actual one too which makes me think it isnt connecting for some reason. Also, it says my wallet is unverified and has a permanent loading symbol. When i try to reconnect uphold says “error something went wrong” and it never connects

Eeek, that is a slew of problems. If you haven’t already, you should update to the latest Brave and OS versions. You didn’t say what your Android version is. I think Brave only supports version 6 and above. Could that be a problem?

Try this for the error message: Cannot Connect Brave Rewards with Uphold Account

Post an update if anything changes. If not, just tag the moderators in your post and ask them to take a look.

Im on android 10 and brave 1.38,113 :(. @moderators

Instead of tagging the moderators, I think you should submit a request here: Submit request form

Make sure to provide as much detail as possible about all your issues. Listing them would make it easier for support staff. Include everything you’ve tried and a link to your post.

Example of listing issues:

  1. Not receiving NTP, inline, or notification ads for over 2 months
  2. Problem enabling Brave Private Ads in brave://rewards: toggle glitches to off position
  3. Cannot reconnect to my verified Uphold account “Something went wrong” error
  4. (continue adding more)

Example of things you’ve tried that did not work:

  1. Tried clearing history/cache, exiting browser, and reopening
  2. Tried deleting Uphold app and reconnecting through website to connect
  3. (continue adding more)

Wanted to say that the discrepancy between your Rewards balance and Uphold is probably because you are unable to connect to Uphold but, be sure to include that in your list of issues. Hope your issues are resolved!