Android 13 Brave Downloads: "Can't Open File"

Continuing the discussion from "Cant open file", pdf files will not open in Brave Browser:

Troubleshooting technical issues is much easier when both the user and support agent practice clear communication. For this reason, we have provided the template below for you to fill out with information about your issue. Please provide as much detail as possible so we can most efficiently resolve your problem.

Description of the issue:

I can’t open any downloaded files

How can this issue be reproduced?

  1. Install Brave on Pixel 6 Android 13
  2. Download .pdf or .m4a
  3. Try to open but can’t

Expected result:

Open, view or play file in browser.

Brave Version( check About Brave):

Brave 1.48.160, Chromium 110.0.5481.77

Mobile Device details

Android 13; Build/TQ1A.230205.002; Pixel 6

Additional Information:

Thought it should have been fixed already regarding Problem: Brave Android won't open PDFs from downloads - #2 by Henry

1 Like

Hello there @discodisco please accept my apologies for this inconvenience. Do you receive an error while trying to open the files or are you redirected to select an app to open it?

No worries @Kevin_cc, the error occurs when selecting to open the downloaded file from the Downloads pane. I am not prompted for any redirection to open the file from an external app. I just see the “can’t open file” dialogue box flash temporarily.

1 Like

@discodisco Please try installing the Beta or Nightly version of Brave to see if the issue persists on those versions.

Be waiting for your response.

1 Like

@Kevin_cc Just got it fixed. tl;dr gosh I’m dumb.

Looks like I had Google Drive disabled, and that it needs to be enabled to read .pdfs from Downloads.

Downloading VLC, I was able to play the downloaded .m4a files.

I download Beta, Nightly, Chrome, and Firefox. I searched “The Egg Andy Wier .pdf” and downloaded the first hit. Same error trying to open the .pdf for all Brave builds and Chrome: “Can’t open file”

The Firefox app gave me the error: “No app found to open this file”

So I checked for Drive and it was disabled. I toggled that and now it works.

Anyways, hope you have a good weekend and sry to have bugged you

No worries, thanks for replying and sharing that information as this could be helpful if other users are experiencing this issue.

If you have any concerns, please let me know or create a new post in order to further assist you.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.