Amazon saying browser doesn't support HD streaming

Everything was fine on amazon until the other day and when i went to load a video i suddenly get a message on any video that says “Your browser does not support HD streaming”

I googled for the answer and i saw people mentioning wildvine but i get no popup asking me to use wildvine. I tried clearing all cookies and history and i still get the same error with no wildvine popup.

3 Likes

Have the same problem :roll_eyes:

1 Like

Yup, seeing this also. I am using the latest version

Me too – did the “Wildvine” thing work or not? Is there a known fix? I hate having to revert back to using Chrome or Edge since I no longer trust their platforms at all…

My problem is i never even see the wildvine popup to interact with.

I have the same problem - I did a frame comparison between Brave and Chrome, and there is a difference in image quality.

For now, I’ll use a boxed Chrome App for Prime, but I would like to see HD content supported in Brave.

Also, I never had the popup for the plugin, but I can’t remember If I have had installed it before.

Same problem, video plays but in a lower res (Brave = 1.17GB/hr, Chrome 6.8GB/hr). Wildvine installed and latest version. Shield off or on doesn’t matter. Surprised so few people reporting the bug but I had a lot of trouble even finding this post/forum, certainly does not show up in search engines.

Looks like it’s the 1080p that’s blocked.

I also had issues with 4k being blocked.

I recently (as of starting this reply about 10 minutes ago) experienced an issue with Amazon video as well, it occurred when by browser received an update to Version 0.66.100 Chromium: 75.0.3770.142 (Official Build). Initially there was an error provided by Amazon video indicating that my browser did not support HD video, which up to this point it had previously without issue. Amazon’s help page simply informs users to use an up-to-date browser, HD is supported on Windows and Mac only (I’m running Windows 10 64-bit version so there’s no issue there and hasn’t been until this point), upon checking Brave’s info, a new build had downloaded (as mentioned above) and I needed to relaunch – I did so. Upon having relaunched I received a different error which I failed to jot down (the gist of it was that there was an error and the video could not be played which happened on all videos attempted to be played during that session) but it linked to yet another article advising how to update the browser and ensure that it’s been relaunched. Obviously woefully unhelpful. In any case, last week I experienced no issues with HD streaming or the ability to play video in Brave at all, today after the update, I’m sporadically unable to play video and HD streaming evidently is no longer supported.

Update:
I’ve since gone through some steps to ensure that the components installed on Brave were updated to their latest version and this seems to have solved the issue for me. Found the issue by checking the components at “brave://components”. I just ran down the list to make sure everything was up to date. Widevine itself (Widevine Content Decryption Module) appeared to already up to date and was not updated (Version: 4.10.1440.18) but other components were out of date.

Additional update:
This definitely does not appear to be a solid fix as the results are sporadic as well. After ensuring everything is up to date Brave seems to allow for HD streaming on occasion, other times the stream encounters an error specific to this update in Brave (in my experience anyhow) as it does not appear to happen in Firefox or Chrome. At this point due to the inability to maintain a uniform experience I’ll just use either Firefox or Chrome for streaming until the issue is resolved with Brave.

Hi @NihilistZealot,

Welcome to community, and thanks for the info that you provided.

CC’ing my colleague @sriram who can help to take a closer look.