Wildvine missing on New Brave



I’ve opened up new Brave now that it’s installed itself and I’m finding that when I go to Amazon Prime Video I get an error saying " Your web browser is missing a digital rights component. Go to chrome://components and under WidevineCdm , click Check for update ."

When I check components however there is no Wildvine. I’ve searched on the net and some people have suggested installing it separately but I cannot see how this is possible because no page prompts me and it doesn’t seem to be hosted anywhere.
Old Brave plays videos on Amazon fine with no prompt about Wildvine.

How do I fix this?


The short summary: go to primevideo.com and install Widevine over it. There should be a message asking you to install. :slight_smile:


Thanks but that just directs me to the UK site, no prompt.


Hi @Galae30,

You may want to try this:

  • Visit spotify.com.
  • There you should see the puzzle icon. At URL bar on the right side.
  • Install and Run Widevine.
  • Revisit Amazon Prime.

Prev. Brave also require opt-in Widevine (disabled by default). You will get the prompt when you visit DRM-protected site for the first time or enable it via Preferences > Plugin.

More or less, similar for the new Brave.
Hope that can help

Black screen on Netflix
closed #6

This topic was automatically closed after 30 days. New replies are no longer allowed.