Amazon Music "Playback Disabled" Windows 10

Description of the issue:
A previously posted issue doesn’t solve the problem


Amazon Music site still displays popup of “Playback Disabled”

How can this issue be reproduced?

  1. Visit https://music.amazon.com/stations

Expected result:
Being able to use the web contents
Brave Version( check About Brave):
V1.3.118
Additional Information:
I followed the instruction described in the previous issue but it didn’t work for my environment.

Thanks for the report, have a possible fix. Just needing approval (as a temp solution, there should be an autoplay icon in the url bar)

Thanks for replying. But actually, this problem occurred after enabling the autoplay of music.amazon.com
I mean there was an autoplay icon in URL bar before I interacted it.

@Anolis,
You’re saying that you enabled Autoplay on Amazon, then saw this error?

Yes, exactly. I enabled Autoplay, then visited amazon music, and I got the error message.

@Anolis,
If you remove the Autoplay permission (set it to block or ask), does playback function as intended?

@Anolis There a bug in the auto-play code (related to my commit). This will be fixed in the next few Nightly builds. But the autoplay in the url will work manually. See the gif below.

@Anolis this should be fixed in the latest release Version 1.4.96

No, it doesn’t work either if I set block or allow.

I have done the exact same way as the gif about autoplay in the URL bar.
But it doesn’t work and I cannot access the contents.
Sorry, I wanted to upload video of my situation but new users are not allow to upload mp4 video.

Now my version is 1.4.96.
But still there seems to be something wrong. Could it have nothing to do with autoplay?

@Anolis,
If you upload the .mp4 to imugr, you can paste the URL here in the editor and it will come up as a nicely embedded video.

Also, I was able to land on music.amazon.com, choose a station, and start playing without any issue on both macOS and Windows. I’m wondering if you should just clear all your site data for music.amazon.com and then try again.

  1. Visit music.amazon.com
  2. Click the “lock” icon in the address bar
  3. Then Site settings --> Clear data and Reset permissions