All settings disappeared. Brave disappeared from launcher. Opens to welcome to brave page

linux
bug

#1

Hi, I am running Ubuntu 16.4 LTS. Version 0.56.12 Chromium: 70.0.3538.77 (Official Build) unknown (64-bit).
Last night I applied a bunch of updates which the Ubuntu updater recommended. No, I don’t remember what they all were.

  1. This morning after a reboot Brave disappeared from the Launcher.
  2. Starting it from the search puts it back on the Launcher, but when attempting to lock to the Launcher, I saw it was already locked!!!
  3. First screen was a Welcome to Brave tutorial.
  4. Message: You are using an unsupported command-line flag. --no-sandbox. Stability and security will suffer.
  5. All my setting are gone. All! No bookmarks. No home pages. No Brave Payments. My title bar has disappeared. My BAT account has disappeared.

What happened? What in heavens name did you do to me THIS TIME?

YOUR. BROWSER. MUST. BE. IMPERVIOUS. TO. UPDATES.

Why isn’t it?

Please provide a step-by-step detailed walk-through or user guide to undo this mess.

Regards, and thank you in advance for a speedy solution,
Joe


Unsupported command-line flag: --no-sandbox
#2

You and me both. (must be at least 20 characters)


#3

This matches my experience also. I also lost New-Tab-Goes-To-Home-Page, a feature that I really liked - I don’t know if this was considered a bug and removed tho’. I can still start the old browser, but the new one seems to have overwritten my previous settings or hidden them.


#4

Okay there, other people are complaining too.
Brave, what are you going to do about it? Today?


#5

Same issue for me too. I can’t properly use the browser until it gets fixed.


#6

Sigh. I hit this too, but slightly different circumstance.

Ubuntu 18.04 and latest. I got some updates a few days ago, but nothing recently. Had used Brave and was open with a few tabs. I was doing something else in another window, and noticed Brave disappeared.

I could not launch it from my sidebar.

Console showed a dozen processes. I killed the oldest. They all went away.

Still could not launch from my sidebar.

I rebooted. Still could not launch from my sidebar.

I opened up the Gnome apps thing in the bottom left corner, and clicked Brave. It launched, but the task bar showed a rotating image next to Brave. Then the window showed up, “Welcome to Brave” and the whole new user process.

I saw the warning about the -no-sandbox setting too.

I can’t sync to get my passwords, stats, and BAT back. Not criticia, but it is SUPER ANNOYING.

Looks like a bad update and an out of bounds update. There are better ways to handle this, especially with Ubuntu’s normal update process.


#7

I found this and followed these steps. One key point was in the new brave-browser to import your settings from “Brave(old)”. However, it does not seem like passwords came across.

I do have my summary stats, but lost all my sites I had queued up for BAT when the next date came. That’s reset.

IMO, this upgrade should have been handled via Ubuntu. I now have ‘brave’ (0.25.2) and ‘brave-browser’ (0.57.18)


#8

Thanks @AndrewB, I’ll try it … when I have the bandwidth to attack this.
BTW, same thing happened on my other Linux Ubuntu computer… nothing to do with Canonical’s automatic updates.

Update…
Okay, I ran sudo snap revert brave and did get back the old version. Fwew. Any opinions if I need migrate to the “newest version” brave-browser? Or I can stay here until the Brave Company gets the s**t together?


#9

Follow the other steps in my link to get 0.5x+ from Brave’s repos. You probably will have (from command line) ‘brave’ for 0.25.x from Ubuntu, and ‘brave-browser’ from the Brave team simultaneously afterwards. You can even run both of them side by side.

After you have what is ‘brave.browser’ installed, run it. When going through the welcome setup, there will be an option to pull in an old profile. On the dropdown is “Brave (old)” along with Firefox, Chrome and others. Choose that.

My stats (time, ads, https upgrades etc) came over. My bookmarks came over. My passwords did not come over.

Also, a developer on Twitter told me that sync, present in 0.25.x, might be back in 0.59, which is the current dev build. There is no sync in 0.57, the current version.

I’m hoping that I now or will soon have the browser from Brave’s repo, as it’s likely to be updated much more frequently going forward on my 18.04 desktop.

I’m still not sure why brave 0.25 botched itself with some automatic download. That’s not a good user experience.


#10

All of your questions (everyone’s) can be answered in one or both of the following articles: For users who had issues migrating data from Brave Muon to Brave Core


#11

This topic was automatically closed after 30 days. New replies are no longer allowed.