Ads not popping for Brave Rewards

Been using the browser for hours now and not one ad. I’m I doing something wrong? How do I get the ads to start flowing?

Based on the tags I assume you’re using the Apple App, or are you on a Mac Computer?

As far as I know, Ads are not yet available for Apple devices. They will be supported in the future.

If you are on a Mac, make sure all your settings are correct. Go to chrome://rewards/ and check that “Brave Rewards” and “Ads” are enabled. If you already received ads, you can see that in the “Ads” section.

I wish that was the case. True enough, I am in the apple echo system but I also have a window 10 laptop that isn’t getting any ads either.

Did you never receive any ad so far or just in the last few hours? (What does the “Ad notifications received this month” say)

I haven’t seen an ad since I installed on neither of my 3 devices. Making my ad count 0. I’ve had Brave for about a week now.

Do you live in the US, Canada, UK, Germany or France? Any other country is not part of the Ad program yet (but will be probably this year).

Or do you have anything activated that could block notifications? Do you have to allow Brave to send you notifications in your OS?

If none of that applies, I have no idea what could cause your problem.

1 Like

Exactly. Idk either. It seems as if many ppl are having this issue. Wish I could fix it. I live in Michigan. I do run VPN but not outside the country. I don’t get it

It would be interesting if you tried browsing without VPN for a few hours (minimum, or until you get an ad). AFAIK it’s not just the location where you connect from that matters, but also the OS settings region and locale.

Ok so that’s where you lost me lol. How would I find that on wondows 10. Please be specific if you can. Im not to good with the windows platform🤦🏾‍♂️

@blacbootz also, maybe this one can help FAQ: Why am I not seeing Brave Ads?

It’s probably setup correctly on your machine. If you want to confirm it:
On Windows search for “Control Panel” and open that App. Click “Clock, Language, Region”. Select “Administrative” at the top. Click “Change system locale…” and select English (United States). You can close those windows.
Then search again, this time for “Region”. It should open a Windows setting where you can choose a country.
(Some translations might be incorrect as I’m using the German version)

However I don’t think your settings are wrong, I think it’s more likely that it has something to do with the VPN. So maybe try browsing without it for a while and then tell us about your hopefully successful results.

1 Like