Ads depend on the number of monitors?

I have been trying for several months to get the notification ads to appear in Windows. Following several tutorials I came to the conclusion that I should change the region of my laptop to the United States, I did it and everything was working for a couple of weeks until it did not do it anymore, so I changed all the settings to the ones I already had.

I have an extra monitor that I use in addition to the one included with my laptop and I always have it connected to it. One day while I was playing, I disconnected the monitor to have better FPS performance and when I started to use Brave I started to get the ads.

I hope you can try this and let me know if it worked for you.

NOTE: When I reconnect the monitor I only get a couple more ads and then they stop, it always works with 1 monitor.

Sounds like Focus Assist. Switch it off and see what happens.

Its already off but thank you, I know it sounds kinda weird but its true, currently i’m using just 1 monitor and now i have ads.

@CharlesKlein Sorry to bug you again on the suggestion that was just given, but I did want to verify. Did you also turn off all the automatic rules? For example, in the screenshot that @CloggyAbroad gave, Focus Assist would turn itself off when duplicating the display, playing a game, or using an app in full-screen. Sometimes people turn off Focus Assist but forget to toggle those Automatic Rules to off as well.

I just was trying to look for issues or solutions and found two different GitHub where they’ve tested and see things working with a second monitor. I also see where you mention you see them for a short and then it stops. It just feels like Focus Assist should be the issue, but double checking here.

Yeah, I have everything disabled, in fact, when I wrote this topic, i had ads, but now i don’t and I don’t see what’s wrong and idk what to do.

The number of monitors you’re using should not affect whether or not ads are displayed. I currently am using a Macbook attached to two external monitors and have no issues seeing ads (this works on my windows device as well). There may be something else at play here — since you mentioned FPS, I’m curious to know if you’re using a laptop and if you have a gaming mouse connected?

1 Like

Yess, I have a laptop and a gaming mouse connected

1 Like

So the gaming mouse is likely the cause of the issue. This is known to stop idle events in the browser which prevents ads from being shown. Can you please try disabling/disconnecting that mouse and testing to see if you get ads when not using the gaming mouse?

1 Like

Wait what? What about a “gaming” mouse causes that exactly?

1 Like

@xMovingTarget A good reference for that can be saying that what I’m going to link below.

That is also listed in one of the things in the summary of issues second sloppy from seeing ads in there FAQ. Link to that is below

You can see that at

Cool, thank you. I was curious about the technicality. Interesting to know.

I disconnected and connected the usb receiver and I got an ad but I got another solution.

  • Go to "Change your mouse settings"
  • Clic on "Additional mouse options"
  • Now clic on “Hardware” section
  • Clic on “Properties” and "Change settings"
  • Go to “Power management” and disable "Allow this device to wake the computer"

Credits to

By now I’ll be testing this method, thanks for your help guys

@CharlesKlein Never did hear back from you. Does that mean the method you tested works?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.