Address bar not working

When I input an address into the address bar and click enter, nothing happens. The problem is not the enter button as it works on other browsers. Help. I didn’t even bother to make a search page so now I can’t do anything with my brave browser. Thanks for your help.

Hey penelopesgardeb,

I’m going to need more information from you if you want us to help you. So:

  1. What version of Brave are you on?
  2. What OS are you on?
  3. Can you provide a screenshot/video of the issue you’re having so I can understand your situation a bit more?

Thank you. I’m sorry. I found out I’m using Brave on Linux and it’s Chrome 91. Chrome! I hope that doesn’t mean it’s google.

As for the screenshot, don’t think that will help. Let me do a better job of trying to explain. For instance, when I wanted to look up the Brave Community to ask for help, I put something like, Brave browswer community in my address / search bar. I don’t have a search page saved on my Brave home page. So I put that in the address / search bar and click the enter button. It always worked fine until a few days ago when I hit enter and nothing happened. I was still on the home page with the search terms in the address bar. Nothing changed. No matter how many time I tried different search terms, whenever I hit enter … just nothing. It’s as though the ‘enter’ button is somehow disconnected from the address/search bar.

I hope that clarifies things for you. Thanks so much for your help!

Penelope