Adding photos to the web via Photos app not working

Description of the issue:

When I try to insert a photo anywhere on the web, I can’t access the Photos app directly on my Mac:

How can this issue be reproduced?

  1. Click on “upload”
  2. Click on “choose files”
  3. Select Photos

Expected result:

This is what happens when I am using Safari:

Brave Version( check About Brave):


Additional Information:

Mac Os Mojave 10.14.6

Thanks for reaching out. Testing on my end, using imgur, I’m able to see/access my photos app on macOS without issue. Can you tell me what site you’re trying to upload to?

1 Like

Thanks for the reply! It’s happening on this site, for instance, but also Facebook, and other sites that allow uploading. Weird that it’s working for you, and not for me, only on Safari it does.

If you try to upload images from other directories, do you get the same results or are you able to do so successfully?

I can add photos from any folder just fine, even Photobooth seems to work. But not Photos. I’m curious to know what OS you’re currently using and if that’s any indication as to why it won’t work for me, but does work for you.

I’m on macOS Catalina, but I’ve never had this issue before even when using Mojave. Does Brave have full disk access to your device?

Thanks again for trying to help. How can I check it has? Where do I look?

1 Like

On your mac, go to System Preferences --> Security/Privacy --> Full Disk Access and see if Brave is listed there. If not, you may try adding it then seeing if you’re able to upload through the photos app.

Thanks. Did that, but still the same. Even turned off filevault en rebooted, still the same. I even tried a new user account to see if it’s account related, but same issue there. I’m at a loss.

Right. I’ve done several testing. Tested it in Parallels with High Sierra running: it worked. Also tested it with a fresh copy of Mojave 10.14.6 running Parallels, and it didn’t work. So I’m beginning to think it is Mojave related, but that wouldn’t explain why it did work with you though. :thinking:

One final update: I’ve made the move to Catalina. All is well now. Working like its supposed to. Thanks for the support, but turned out not to be a Brave issue I think.

This topic was automatically closed after 30 days. New replies are no longer allowed.