Unable to upload anything

bug

#1

I cannot upload anything using Brave. If I want to upload a picture to an image hosting site, I can’t do that, no matter what site it is. If I want to upload a file to a cloud storage site, I cannot do that. I cannot upload anything at all.

I figured that this needed its own topic. I am using version 0.58.18 Chromium: 71.0.3578.98 (Official Build) (64-bit) on macOS Mojave 10.14.2. No other browser exhibits this behavior.


#2

@ema1982,
Are you uploading with Shields Up? If so, try with Shields down to test whether its a Shields issue or not. On my end I’m able to upload images (and other things) without issue:


#3

I turned off the shields and I still have the same problem.


#4

Lets try another test:

  1. Right-click the image below :point_down: and select “Save image as”. Save the image somewhere.
    brave-lion
  2. Now, right-click the image again, but this time select “Copy image” from the context menu.
  3. Now hit reply here in this thread to open the editor
  4. Right-click and paste.

Did your copied image paste successfully into the editor/your reply?

Either way, next try:

  1. In the editor again, click the “Upload” button on the toolbar :image
  2. Find the image you saved a moment ago and try to upload the image (you can also try dragging the file from the folder its in directly into the editor to achieve the same effect).

Did the image upload successfully?

Let me know the results.


#5

brave-lion

I was able to copy and paste the image.

brave-lion

And I was able to upload it.


#6

Excellent!
Now try and return to one of the image hosting sites you attempted to upload to before (if you could tell me which one(s) you used that would be helpful as well). What happens when you try to upload it?


#7

First of all, thanks for the help.

Unfortunately, when I try uploading anything to Imgur.com, real-debrid.com or gab.com, it’s the same. I’m unable to upload anything anywhere else. It works fine in Safari.

I think this started to happen a couple of updates ago.


#8

Is there an error message or anything that’s displayed when you attempt to?


#9

No, no error message.


#10

Would it be possible to see a screen recording of the behavior?


#11

I’ve got a similar problem with widespread file attachment failures. I captured the errors from the developer console when attempting to attach a file in FogBugz, which is where the problem affects me the most since I work in it all day. :slight_smile:

console


Release Channel update 0.58.21 is LIVE!
#12

This is a known issue with CORS that I believe we already have a fix for rolling out later today. If @ema1982 is experiencing the same issue then hopefully both will get resolved by the end of day :slight_smile:

Keep your eyes out for a browser update today and let me know if they issue is resolved along with the update.


#13

I updated, and it worked like, once, but I wasn’t able to upload anything else.


#14

Hi @ema1982,
Something isn’t right if you’re still encountering this. I’m able to upload without issue using the same system settings you listed.
Here’s my suggestions to try:

  1. If you can get a screen recording of you attempting to upload an image it would be very helpful. There is a free, safe, open source and extremely easy to use program called LICEcap that you can download and use in a manner of minutes to accomplish this.

  2. Try uploading images from a private window. Private windows use different protection settings and often times can help reveal the cause of an issue in standard window browsing.

  3. Similar to the above, you can try creating a fresh profile and attempting to upload images there. Sometimes profile data can get corrupted or mixed up internally which may be causing the issue you’re encountering.
    Trying on a new profile will help rule that possibility out. To do this, click the “People” icon next to the menu on the top-right of the browser. Go to Manage people --> Add Person. Brave will launch a new window and display the welcome tour. Try to upload on this profile.

Let me know what you tried of the above (if anything) and the results. Would love to get this sorted out for you.