Add app to Home Screen doesn't work

Add app to home screen or install app doesn’t work although using chrome it works.
Also, when changing the default launcher then it works but not with default launcher.
I have tried many times but icon doesn’t appear at home screen or anywhere.


How can this issue be reproduced?

  1. Add Home screen app/Install app

Expected result:
The icon of particular website should have appeared but it doesn’t.

Brave Version( check About Brave):
1.33.106, Chromium 96.0.4664.110

Mobile Device detailsVivo 1603

Additional Information:
If I change the default launcher to like microsoft launcher then it works but not with default.
Although no issue with chrome browser.

1 Like

Lol, no one replied yet

In Pixel 3 i have no issue. I tried adding twitter home page it worked. I am not sure it is specific to the launcher you have or specific to the website. BTW, can you share what website you are trying to add to home page?

:point_up: I would also like to know this information. On my end the function works as intended.

I’m not saying this is a bug for everyone but for me it is and it’s for every website and also I use chrome which works fine.

This issue get fix if I change my launcher to microsoft launcher…

When you tap Menu → Add to home screen, are you prompted to name the shortcut as well as the additional prompt to Add to home screen?

I basically get install home option which I press ok, but nothing adds.

Also, this is not the first time I’m using add home screen feature. I have used it for months but it was in different launcer (microsoft) but then I suddenly removed it and get back to default launcher. Then I tried to add but it didn’t worked.

@Adison I am assuming you’ve considered this and the issue is elsewhere, but I want to ask because sometimes the “silly” or “simple” things can get overlooked. Do you have multiple “screens” on your home page? If so, did you check those?

Again, I know it’s silly, but the reason I ask is I originally went to test this out like you mentioned and nothing showed up on my primary screen. However, when I swiped over 2 screens, the shortcut was sitting there. I’m not sure why it added to the location it did. I’m also not sure why I swiped over, because I hardly ever go to it.

Anyway, going to add one more little thing in a moment, just had to get onto my Android. So there will be a small follow-up with screenshots once I can do it…


Then from there when I just hit Add it went to the third screen/page like I mentioned. But other option is pressing and holding down on the icon, which then will “snap” to the home screen and allows me to choose exactly where I want to place that icon.

Question is, do you get the same options? Have you tried pressing and holding the icon to place yourself instead of choosing Add?

Again, maybe a long stretch and not the issue, but figured I’d ask just in case and for better clarification

Hello, @Saoiray thanks for replying

I only have 3 screen and checked all of them
I also tried with chrome and it works with chrome.

I’m not sure how you got that option.

Which icon?

Also, If you guys thinking that I’m doing a silly mistake then it’s not.

Cause I have chrome which adds website app to the third screen of my apps section.

Maybe it’s not a big issue cause I’m in minority or rather I’m only facing this issue or it’s hard to repeat this issue for other guys. So I think no solution gonna come out.

In the screenshots I had provided, on the last one you’ll see where it shows the name of the website Asure Scans - Read Comics followed by a 1x1. Under that is the icon which would appear on my Android’s home page. If I press and hold down on that, it will then switch to my home screen and the icon will be at my finger, allowing me to place it any specific place I want. Whereas if you didn’t touch and hold the icon and instead pressed Add, it would randomly try to place it somewhere.

Sorry if it came across like I’m saying it’s a silly mistake. I’m not sure if you ever heard the joke or anything, but long ago tech support found one of the biggest reasons why things didn’t work was because people hadn’t plugged in their products. “Why isn’t my printer working?” Sure, they had power, but it wasn’t connected to the PC or whatever.

So it was just in the spirit of things that I do come and ask JUST IN CASE anyone seeing it might have just somehow rushed and missed it. But also in this situation, I wanted to find out what happens when you do press and hold on that icon…or even see if you are reaching that particular screen yourself. Main thing is, just having to find out exactly what you’re seeing and experiencing, that way someone might be able to help figure out precisely where things are going wrong.

@Adison All of my above comment said, I want to go back to yours.

Underneath this comment, I’m going to switch to my Android and upload screenshots detailing the steps. I’m assuming they are all the same steps you did BUT you’re telling us that the menu option we see is something that is not showing for you.

I just wanted to put the steps for you to check again and to tell us if that is indeed the situation. If so, then that might narrow it down more but then it would be more complex than I have knowledge of and we’d be relying on @Mattches to continue assisting. But at least we’ll have it down to details. Or if somehow it solves things, then we can know that’s done too.

Step 1
Go to website

Step 2
Click on 3 dots to open Menu/Settings thing. It will show all you see here.

Step 3
Click on Add to Home Screen. Then you can name the shortcut or just tap Add

Step 4
Press and hold on the icon that appears OR hit Add

Step 5
The icon should now be on your home screen. If you had done the Touch and Hold icon, it would have snapped to it and you would place the icon first.

So yeah, I guess it’s just affirming. Are you not seeing all those steps yourself? If not, where does it break and how?

I literally didn’t mean it like that, I was just making you guys assure that I’m not doing any silly mistakes.

Also this isn’t the first time I’m using this feature. I mostly prefer using web app compared to mobile app to avoid more storage.
Using it for like 3-4 months.

I’m still using this feature using chrome.

Also, I have done the same thing in my case, I have choose the same website that is reddit everything was same till add to home screen option where I just tap add and It will say it’s been added to home screen.

So step 4, doesn’t come for me.

1 Like

@Mattches so narrowing down where the issue is happening , would you have any ideas? Not sure if idea that Adison had switched launchers before matters? If might be something in cache or w/e of the app itself? Sadly I’m limited on knowledge here. But does seem it’s an issue with “communication” between the browser and Android, right?

This might help,
Go to settings>apps>brave>permissions>home screen shortcuts> allow

1 Like

brave have all the permissions

I was facing the same issue and this solved my problem