Ad blocker is not working youtube

Brave is not blocking the ads and specially on you tube i tried many times but the ads always showing. what should i do

@Humayon

When you create a Topic here, please choose tags and all to go with it. Yours was made Uncategorized. Ideally you would have chosen Browser Support > Ad-blocking. Then it would have given you a form with information to fill out. I’ll go ahead and try to request more info and then I’m also going to move your Topic over to the right place.

  1. What operating system are you using? (please don’t just say Windows or Android, but instead Windows 10 Pro or Android 11. In other words, be specific please)

  2. Which Version of Brave are you using? (give the number, don’t just say “newest” or “latest.”)

  3. Which type of ads are you seeing? The ones that play in the video or ones on the page?

  4. Is Brave Shields on?

  5. What settings are you using for Brave Shields?

  6. Does this issue happen if you open in Private Window?

Lastly, check out:

-AND -

I am facing the same issue.

From the past 3-4 days I’ve noticed that the ads in Youtube have started to show up. It is the ad that we get before the chosen video plays.
We get the option to skip the ads the way we do it in other browsers.

Here are the details as requested:

OS: Android 9 Build/PKQ1.180917.001
Brave Version: 1.41.100 Chromium 103.0.5060.134
Cleared Caches and Cookies, Rebooted the phone.
Brave Shield is on. Settings were Standard earlier, but I have tried aggressive too but issue remains.
Issue persists in private window as well.

One more issue that I noticed is that when we tap on a video to play it, we get the play icon on the video and we have to tap on it again to start playing the video, earlier, it used to start playing the video the moment we tap it the first time.

Any advise would be appreciated.

Thanks
Ashutosh

@ashutosh912 Just clear the cookies and then relogin into youtube. Ensure shields is up, It should help with ads.