9gag is not loading properly on Brave browser

When I open 9gag doesn’t load properly and when I tried close it I get a bit of lag (1-2 seconds). I tried turned off brave shield and it still doesn’t work. I tried on chrome, firefox and opera and it’s working just fine. It works just fine like a week ago. I have Version 1.2.42 Chromium: 79.0.3945.117 (Official Build) (64-bit) version.

Can someone else try open 9gag if I’m the only one with this problem. I just wanna improve brave browser.
Sorry for my bad English


Thank you for bringing this to our attention – it looks like I get the same behavior when going to 9gag. The site starts to load but seems to “stop” rendering midway and then freezes. Closing the tab results in the tab hanging for 1s-2s as you described.
Reaching out to @fanboynz to look into this issue.

1 Like

Thanks for the reply. I think it’s something in the new update because a few days ago it was working fine. Good luck


Have pushed out a temp patch, not sure if it’ll work, but we’ll see.

1 Like

Still loading improperly. I also have 1-2 seconds lag when closing the tab.

same for me. It works when I put the shield down. But I don’t wanna put the shield down :cry:

yeah… now atleast works without a shield… I hope they figured out what is causing the problem. I can test it with an older version of brave if it’s that, that causing the problem

give it 24-48hrs, see if my changes affect it or not

still there :frowning_face:

I rolled out another fix yesterday, still investigating whats going on

Just opened 9gag, still having the same problem.

Still have a problem with 9gag

I’m experiencing the same issue as well. Tried to reset all cookies/data/permissions, issue persists, but works normally on any other browser.

This maybe resolved in Brave Beta. Can someone confirm?

9gag is not loading properly on Brave browser…
mybkexperience survey

I am having the same issue here on two of my PCs.

Same issue on my PC, I am getting a “Page Unresponsive” every time when I am trying to load 9gag with Brave Shield up.

To all the reporters of this bug, can you re-test in Brave Beta https://brave.com/download-beta/

I didn’t see any lockups in the Beta.

1 Like

I tested with Brave Beta.
9Gag works again for me!

1 Like

Thanks for confirming. I’m not sure what is causing it, temp fix, disable site-trackers for the moment, or use Brave Beta (this will be rolled out to Brave Release soon)