1Password extension fails to install

I posted this in the 1Password support community:

Fresh install MacOs and 1Password. Chrome extension runs fine. Brave install fails in Chrome Web store. I’ve tried numerous times (and rebooted the machine) failure is always the same after clicking “Add to Brave” and then “Add Extension”
“An error has occurred”
“Download interrupted”
at the bottom of the browser window
“aomxxx…crx”
https://go-updater.bra….”
Failed - Server problem

Help! I can’t stand Chrome and need Brave. Brave and extension runs fine on my older laptop (MacBook Pro)
In response to their question I added
This has been going on for a couple of days now. Yes I can add other extension to Brave (just added and removed JSONView) and I did just install Flash (needed by Bank) with no problem. On my old MBPro (which will be flatted soon). I removed the extension and could not reinstall it: same error as on my new machine.

Are you behind any VPN? If so can you try disabling it and check if you can install?

No VPN, again Chrome has no difficulties. Its not just 1Password extension, ANY large download seems to fail now, small stuff succeeds. I thought it was the Brave server, its not, its Brave browser choking on downloads
This has waisted way too much time … I’ll return to Chrome