YouTube: Ads are bypassing the blocker

Description of the issue: Ads are sometimes popping out on YouTube even if my brave is updated

Exact URL of the website in question: https://www.youtube.com/watch?v=TlKCoEH-vYw

Screenshot of the ad as it appears in Brave
Did the issue present with default Shields settings? (yes/no) Yes

Does the site function as expected when Shields are turned off? Yes

Is there a specific Shields configuration that causes the site to break? If so, tell us that configuration. (yes/no): No

Does the site work as expected when using Chrome? Yes

Brave version (check About Brave):
Version 1.26.74 Chromium: 91.0.4472.124 (Official Build) (64-bit)

Screenshot of the error:

Does clearing brave://net-internals/#dns then reloading the youtube webpage help? @luigioctaviano

Hello, my problem is that I added a custom filter to remove the recommendations that appear at the end of youtube videos and suddenly it has stopped working.

Type brave://adblock in the address bar and delete the custom filter from the Custom Filters textbox at the bottom of the page.

But I set that custom filter so I wouldn’t be bothered by recommended videos and it no longer works.
Can something be done to block the recommendations that appear at the end of the youtube videos?
In the other browsers the custom filter does work.

Sorry, I misunderstood you. I read it as YouTube stopped working for you after you used that custom filter.

Post that custom filter over here so @fanboynz can take a look whenever he can, although that’s a bit off-topic to me as the thread is about video ads whereas you want a custom filter so you’re not bothered by recommendations after the videos.

Ok, this is the custom filter:

##.ytp-ce-element

Thanks

Yep it works perfectly fine now, tried it just now. Thanks a lot!

Sorry for the late revert :slight_smile: