Wrong date format (always MM/DD/YYYY)


Description of the issue:
Despite of the Windows system locale settings and the Brave language, dates on websites are always displayed in the MM/DD/YYYY format.

How can this issue be reproduced?
For example navigate to https://www.idea-r.it/it/blog.aspx

Expected result:
If your are an italian you should see the publish date of the blog articles in DD/MM/YYYY format (use Chrome for example), but they are displayed always as MM/DD/YYYY.

Brave Version( check About Brave):
1.14.84 Chromium: 85.0.4183.121 64 bit

Additional Information:

Hey @IgorDR
It worked fine for me.
Look: DD/MM/YYYY

That’s a mistery.
In my case, it works on Chrome:

…but not on Brave:

Is this an attempt to increase the number of hits for your blog articles? :face_with_raised_eyebrow:
Because the date display works fine.

Hello @IgorDR

go to the language setting in brave
brave://settings/languages

then pick the language you like if you choose english then use uk not usa then click on the 3 vertical dot next to that language then move to top

then go check your site and refresh it

hope that help and have a nice day

1 Like

@justsomeone1 @IgorDR
i did so (yes i’ve relaunched) and had the same result than before. MM.DD.YYYY
so it is not a conflict in the code of the browser.
It shows me also Dot (.) not Dash (/)

what is the first language from the link i mention?

Thanks @justsomeone1, I solved the problem.
I had two languages in my list: first “English” and second “Italian used for UI”
Moving down English, solved my issue, thanks!

@mobydick_2015 I do not need to increase my blog visits, using non-targeted visitors.
I’m just debugging my blog and, thanks to more useful advices than yours, I solved the problem.

you welcome and congratulation for your blog and good luck

Sorry. I’m glad you managed to fix the problem. There are so many spammers promoting their content these days that anyone can get it wrong.

1 Like