Win10 compatibility, is Win8 compatibility required

Installed the latest version of Brave on a fully updated Win10 machine, but browser will not connect to anything until I set the compatibility setting to Win8

Would hope that I could run Brave in true Win10 mode

Brave is up to date

Version 1.10.93 Chromium: 83.0.4103.106 (Official Build) (64-bit)