When I try to print from Gmail I get a blank screen in Brave

Description of Issue: When I try to print an email in Brave, a blank popup window shows up.

Steps to Reproduce:

  1. Open an email in Gmail
  2. Click the print button

Actual Result

  1. Blank Window:

Expected result: Printable page

Reproduces how often: Every time

Operating System and Brave Version: Windows 10; Brave Version 1.3.115

Additional Information: I have turned off the shield for gmail; It is a Gsuite account; I’ve tried printing to PDF AND to regular printer, both don’t work; Print works fine in Chrome on the same computer and same account.

Hi @cbenson82, welcome to Community!

Can you try printing a different email and seeing if you get the same results?
Also, can try opening More settings and letting us know what you see?

This has been an ongoing issue for a few weeks and I’ve tried to print lots of emails and drafts of emails and it never works.

Here’s the “Additional Settings”:

Thanks for any help!

Sorry @cbenson82, I meant more settings within the email print popup window.

I think what @Aa-ron mean was to try using the system print dialog to try and print, rather than printing directly from the browser:

1 Like

Oh, sorry for the confusion, here’s a screenshot:

If you print the email does it also print blank or is it just blank in the popup windows?

Also, can you try enabling headers and footers and/or background graphics.

It prints a blank page if I print to printer. I tried enabling headers and footers and background graphics and just get this

Did you trying try using the system print dialog to try and print, rather than printing directly from the browser as mentioned above?

Yes I tried the “System print dialog” and got the same blank page to print

@cbenson82, we appreciate your patience and time working with us. I’ve got a list of things for you to run though to see if we can further diagnose the problem.

To confirm, this print issue persists over different sites or just on gmail?

Can you try disabling any extensions you have on (one by one) and seeing if the printing works?

Does the issue persist in a Private Window or New Profile?

Can you try clearing browsing data? brave://settings/clearBrowserData

Lastly, can you try resetting Brave? brave://settings/reset

Ok I went through every extension and finally found the one causing the issue. It was Loom - the video recording app. I uninstalled it and reinstalled it but get the same issue so there must be some glitch with the extension. Will just leave it uninstalled on Brave. Thanks so much for all your help!

1 Like