Website not displaying correctly in Brave only

A website I run recently changed webhosting company. Since the change, for some reason the website does not display correctly in Brave only. I’ve tested it in Chrome, IE, and Edge and it works fine there. These were all on my Windows desktop PC. It works fine on android Chrome and IOS Safari.

The website page in question is here:

What should happen on that page, is someone clicks on one of the images for whichever product they want, and then drop down or text option fields appear depending on what is chosen etc.
i.e. In step 1, they choose a product. For whichever product they choose an option field appears under it in step 2. Then once they;ve chosen in step 2 the step 3 option appears if appropriate.
It’s worked fine in all browsers for years.

Now though in my Brave browser on my desktop, all the option fields are displayed all the time. See the screen shot attached. In that screenshot I’ve opened the same address in each of Edge, IE, Chrome and Brave. Brave is the only one showing all the fields.

I’ve no idea why this is happening, as it has only happened since I switched webhost, however since it is not happening with any of the other browsers, and there has been no change to the webpage coding, I’m not sure what’s going on, but don’t think it can be an issue with the webhost. I’ll reiterate, it even works fine in Internet Explorer!!

I’m running : Version 1.18.70 Chromium: 87.0.4280.101 (Official Build) (64-bit) and it says it is up to date.

Any guidance on this one would be appreciated!

Trying to understand what the issue is, looking at the screenshot posted. It looks like Brave is doing it correctly (noticing the drop down menus are being rendered and not on other browsers)

Does disabling site trackers/ads in shields, does it help?

No, Brave is the only one doing it incorrectly. The drop down menus are not meant to be visible until the user clicks on one of the pictures, then only the menus associated with that picture are meant to be visible. Brave, top right, shows all the menus all the time, which is wrong.

I’ll give that a go. However, I have not made any changes to my browser settings since before I moved webhosting company, and it used to work.

I initially thought it might be some DNS thing due to the move, but it’s now been over 2 weeks since the move and nothing’s changed!

Edit: playing with all the settings in the Shield bit, on/off, trackers and ad blockers standard, off, aggressive, etc. made no difference.

Just tested Chrome (see below, cookies were cleared): getting similar results in Brave. getting the dropdown menus.

Oh crap… that may also explain why I’ve had a lot less orders recently!

Why is that happening on your Chome but not mine?!

I’ll try clearing my cookies in Chrome and see what happens.

Ok, cleared my cookies in Chrome and I’m getting it appearing as it is supposed to, no menus visible until image clicked.

I’m more clueless now than I was before. It clearly isn’t a Brave only issue then.

I believe it has to do with your invalid ssl/https certs. (which looks like its causing the browser to block jqueryui)

Oh, I see. I have no knowledge of those, they are just whatever came with the webhosting company.

I’ll have to have a look to see how I can fix that, but thank you for identifying the issue!!

If you know how to fix it, that would be even more awesome!!

Talk/email to your webhoster, investigate why the https cert is failing. Send them this forum link.

Awesome, if I can’t figure it out myself from the Plesk control panel, I will do, thanks!

1 Like

I think I’ve got it all sorted.

Would you mind confirming if you are still getting all the drop downs or not on your machine?

I’m not on any of my machines (home or work) on any browser.

Seeing as youve seemingly resolved your issue, thought id bring up another display issue to save making another thread.

1.18.70 Windows
Aggressive trackers and ads, strict fingerprinting

The text appears normal after scrolling and giving it time. Not a big deal really, but thought id bring it up.

I can read it right away (1.18.70 Windows 10).
But I don’t have the aggressive/strict configuration.

strict fingerprinting

Can cause issues, Maybe tune this down and retest. I Just viewed the site without issue

1 Like

Still happening and I noticed it happens in Edge too. Maybe an issue my end, of some description, rather than Brave.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.