Drop down menu not working


A gaming website I frequent often includes a drop down menu for me to change my selections like switching over to a different account. However, no matter my selection it always refreshes to the same page. It will not take me to the other accounts.

How can this issue be reproduced?
image

pasted image shows options, but it won’t change.

The fix would be for it to change to the account I selected.
Works fine in FF and Chrome.

Version 0.68.142 Chromium: 77.0.3865.90 (Official Build) (64-bit)

If you disable sheilds, does it help? Which site is causing the issue?

I disabled and still doesn’t work.
To add to the confusion, it works fine on mobile version, just not on pc.

site is whatifsports.com

@JCornette,
Can you try Shields Up, opening the panel and selecting Allow all cookies in the cookie control setting?

Also, if you attempt to open one of the accounts from the drop down menu in a new tab, does the new tab open to the same page?

Tried the all cookies - no luck.
Tried doing a right click and open in a tab, but that option doesn’t show.

I contacted the site support and they’re only advice was to make sure javascript was running.

Just to confirm – Javascript is running, correct? Do you have any extensions installed in the browser at this time?

I have the scripts blocked, so that means java is running right?
Got a few extensions but none that I would think would effect this.

The site works fine in chrome, which I read is what Brave is based on.
In Chrome the URL includes a “default.aspx” at the end that does not show in URL while in Brave. I add it successfully, but when trying to switch accounts it disappears and right back to where I was.

@JCornette,
Can you send me an image of what your Shields panel looks like on whatifsports as I’ve done below for community?

Can you expand the screenshot the cross-site trackers blocked?

image

Just to confirm, disabling the site-trackers in sheilds, does that change anything?

no luck disabling. I tried about every combination of things off and on from shields, None seem to work.