Webpage colors are inverted

Description of the issue:
iPad 6th generation: Brave spontaneously started presenting web page colors as inverted, ie, white backgrounds are black and black fonts are white. This affects some images also. I deleted Brave and reinstalled, it worked fine for a few days and then did it again, spontaneously.

This is on my iPad, but not iPhone. So far, it is not doing it on my wife’s iPad.

Research indicates it may be a problem with Chromium.

Steps to Reproduce (add as many as necessary): 1. 2. 3.
Spontaneous. No steps required.

Reproduces how often:.
Occurs once and stays that way until Brave is uninstalled and reinstalled. Then repeats.

Operating System and Brave Version(See the About Brave page in the main menu):
Brave: Version 1.14.2 (
iOS: 13.3

Additional Information:

Uninstalling and reinstalling is a pain because I lose my bookmarks.

1 Like

After googling, I only see a system-wide setting on ipad/iphone. Check this isn’t set?

Thank you for your response. I had found this (or something similar) with my research, but this applies to all apps. The problem I am having affects only Brave, and it goes away if I uninstall and reinstall Brave (but has twice slipped into inverted colors even then). I have once again uninstalled and reinstalled, and so far it has stayed normal. But it has been less than 24 hours, so who knows if it will do it again.

1 Like

I have the same issue as you do with webpages being inverted on Brave on my iPhone. It’s not even consistent which is the weirdest thing. Sometimes stuff will be normal and sometimes stuff won’t be example being the Brave logo and my profile photo in this attached picture. image|231x500

Hey all, just to let you know. We have localized the issue and will fix it in some future release, sorry for troubles.

Relevant ticket here https://github.com/brave/brave-ios/issues/2304

I’m also having the issue with no fix as of yet. This is the second time this has happened after I uninstalled the app the first time around. I noticed when I turn on block scripts it stops inverting the page. Which means it is an issue with the app itself. I also do not have classic or smart invert colors enabled on my iphone. I have also turned off dark mode and it has not fixed the problem. As stated above the inverted webpages go away when I block scripts so it is 100 percent a bug in the app itself. Please fix this bug as soon as possible.

Next release(1.15) will fix it. Sorry for that

Since 1.15 is out, have you seen the inverted colors recently?

As of now I have not, I will keep you updated with context if I do.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.