Webcam not loading in Brave

Hi there, for some reason, I am unable to use my webcam in Brave. I have searched the net, did some troubleshooting, but my webcam works in Firefox, Zoom etc.
It only in Brave. I checked windows security & privacy menu, and activated the camera, however Brave doesn’t show up in the list of apps authorized.
It shows up under the "Let desktop apps access your camera, but only shows as “last accessed 09/01/23”.
I browsed through the settings in Brave, cannot find anything relevant to change.
It suddenly stopped working, and have no clue why. I suspect it is linked to an update of the software.
Any advice? or a flag I should change somewhere?

Thanks in advance

Hello @Joe_tFb, thank you for bringing this to our attention. What kind of device and OS do you use? Have you tried deleting cookies and cache recently? Do you use extensions? Does the same happen in a private window?

Have you check under brave://settings/content/camera > Sites can ask to use your camera should be ON. Let us know if that helps. Have a nice day!

Hi Jarc, thanks for your reply.
I use a Windows 11 desktop PC. Everything is up to date.
I do use extensions, but they never interfered in the past.
I have tried clearing cache and cookies, to no avail.
I have checked under brave://settings/content/camera, and site can ask to use the camera (and do, I tried selecting “until I close this page”, “for 24h” and “forever” to no avail).
It does not work in private tabs.

FYI, I tried to test the camera using, and I get the following error: “NotReadableError: Could not start video source; Object”

Again, Zoom happily works, The site I am trying to use the webcam with works in Firefox, so it seems purely linked to Brave.

Thanks again

@Joe_tFb I’m going to kind of blindly ask some questions/steps which will require you to test out some changes. Do each separately, don’t combine questions/steps. Not really listing in any particular order, so feel free to test in whichever order you wish. These are just little things that I know have helped resolve issues for others in the past.

Question 1

Can you Create a new profile, which you can do via your hamburger menu? Just curious to see if it will work there. I’m assuming it won’t since didn’t work after all else you did, but just kind of a final part of basic troubleshooting steps to help narrow if it’s an issue from within the browser.

Question 2:

Just kind of curious, could you double check your Windows settings to see if you have Brave authorized? I’m assuming it’s on since you mentioned Firefox, but just kind of looking at a random thought here.

Question 3:

Do you have an antivirus or internet security program or extension? If so, mind at least temporarily disabling it and seeing if it makes a difference? Perhaps same if you have a firewall enabled. (I’m assuming one of those could be blocking access). If it works after disabling, then you’ll know need to get into those to have it allow Brave to access or get rid of them.

Question 4:

Mind checking to see if any updates are available to your drivers? Also, you didn’t mention which version of Brave you’re using, so make sure it’s on the latest. (Yes, I know you said everything is up to date. Just is one of those, “would you double check” moments)

Question 5:

When you were at brave://settings/content/camera do you have a dropdown for camera option? If so, can you make sure it’s the right camera? For example, mine shows:

What I’m 100% uncertain of is if having a different camera selection can make a difference. I highly doubt this will have an impact, but thought I would mention it as a trial by fire, so to speak.

Last Question

If you go brave://settings/content/all and then to one of the sites, such as your one, and change it to Allow instead of Ask, does it make a difference? (Note: For screenshot I just randomly clicked on a site and then changed to Allow. Mine is usually on Ask, I just did it for the screenshot, lol)

Hi Saoiray,

Thanks for the answer.

Here are the results:
1/ Creating a new profile didn’t sort the issue.

2/ Brave is on in the settings:

3/ I tried with Antivirus and Firewall turned off, no luck.

4/ Brave and all drivers are up to date (I check daily)

5/ I’ve only got 1 webcam, which is my USB camera, selected in the menu.

6/ Setting the website to allow doesn’t change anything.

I am quite weirded out by this, as I do not have the issue on other browsers / computers.

Let me tag @Mattches and @SaltyBanana to see if they can help. Just a habit of mine as they tend to handle more of these issues. Though of course since @Jarc-1107 was helping earlier too, I’ll tag in again so they can review everything and see if have any further input

Hi @Joe_tFb

I know it might be silly but it’s typical IT support stuff - have you tried disconnecting/reconnecting your camera and test if it works?

ha ha ha,

yes I have, and the camera works when used in Zoom, Firefox and other software.
It only fails in Brave …

Thanks for confirming.

Could you specify which application you are trying to use your webcam?

it simply doesn’t work anywhere in Brave. is where i checked if it works, but I do online surveys with Usertesting (, and I gave permission to use my camera but it doesn’t work.

Appreciate the detailed initial report and subsequent information you’ve provided. Very strange that the camera would just stop working like that. I’m inclined to think it is in fact a Brave problem but that being said, I can’t reproduce this on any other OS.

I’ve asked some folks from the team to see if they can reproduce on Win11. In the meantime, can I have you try downloading Brave Beta and test to see if your webcam gets picked up/works there?

Note that downloading/installing the Beta will not overwrite your current installation or any information therein. Additionally, once you’re done testing, you’re welcome to uninstall it if you’d like.


1 Like

Hi Mattches,

I tried and Brave Beta presents the same issue.

Thank you for confirming.
I know that you’ve tested in Firefox and I hate to ask, but can I have you download Chrome (temporarily) and test the same behavior there and tell me if it works properly? If the issue persists in Chrome, it is likely a Chromium issue that will have to be fixed upstream.

Thank you

Hi There,
It seems to be a Chromium thing, then, as I encountered the same issue in Chrome (and that was before any extension was installed, so I am not sure what is happening.

Thank you for confirming. Basically it means that the issue is likely contained in the underlying engine (Chromium) and will have to wait for this issue to be resolved on the Chromium end.

I’m going to look and see if I can find the specific Chromium issue logged.

1 Like

Thanks a lot for your help in the matter!

1 Like

Hi, I just wanted to add another data point. I’m also having this issue in the latest release version of Brave (v1.50.121), but my webcam works in Brave Beta (1.52.84). I tried reinstalling, deleting my profile, and rejoining the sync chain to no avail.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.