Web Whatsapp doesnot work after the last update

After upgrading to the latest version, my web WhatsApp stopped working.
I use my iPhone to scan the QR code. It reads but after a few moments he reads again and finally, nothing happens.
I get this error message - " database error occurred on your browser. Please restart your computer and relink your device."

I have restarted my MacBook Pro a few times but getting the same result. I am using Big Sur the latest version on my mac and likewise the latest os on my iPhone.

When I use the private window, it works. I have also cleared all my cache a few times and disabled all extensions but still the same result.
I have also disabled the Beave Shield and had the same result.

Please advice.

2 Likes

It is working on my end. You seem to have done everything on your end to make it work. Still create a new test profile from top right-hand corner hamburger menu. In this new profile, do not add or change anything, then see if whatsapp web works normally.

Is your macbook pro on the new M1 chip. I have read that brave (or other browsers) having problems on m1 chip.

Same Problem here from last weeks.

“database error ocurred in your browser please restart your computer and relink your device”

Working on Imac, with Mojave, and Iphone-X.

I tried with my wifes phone, and didn´t connect too…same error.
With other browsers like firefox and safari; watsappweb works fine.

I have watsappweb on Brave; on other Imacs, and MacbookPro, working with Mojave to ; without problem.

Any tips??

I tried to dellete all cookies, navigation, historial, reset site permissions…none works.

I have to say: It is working on Brave, but if I open a New Private Window.

What`s the problem here?? Strange to me…If Anybody knows, please share.

Thanks.

same problem, donno wassup wit whatsapp :sweat_smile:

Had the same problem on my Linux machine.
Here is how I solved it. Like @chh_68 said, make sure you are logged into a profile.
On the hamburger menu (top right)>> create profile, make sure the profile is visible.
It should now work
That the only thing I changed on my computer.

Yup !! Im facing too.
is it due to the browser version of 100 ???.
restart/ uninstall browser / mobile app also.

solve this .

It only occurred in Firefox private mode. If is properly to use on Firefox normal mode or Chrome private mode.

I got a similar problem to yours but a few days after than you.

The error is likely on brave’s side and my guess is cache.

@Mattches

(For visibility)

@chh_68,
Thank you for tagging me — digging into this and hope to have more information soon.

Just googling, came across this video, can people try this?