Watching netflix causes system lag every second or so

bug
#1

Description of the issue:
Watching netflix causes system lag every second or so

Steps to Reproduce (add as many as necessary): 1. 2. 3.
It can happen just while netflix is playing and I am dragging a window. It happens while playing games too

Actual Result (gifs and screenshots are welcome!):

Brave https://imgur.com/nmbeXpB

Expected result:
Firefox: https://imgur.com/JEzmOAg
Brave Youtube: https://imgur.com/TMwAA1u

Reproduces how often:
Every second or so while streaming netflix

Brave Version(See the About Brave page in the main menu):
image

Reproducible on current live release (yes/no):
Yes
Additional Information:

This is able to reproduced any time I load netflix on Brave. This was also happening with Chrome, on my previous system and is why I switched to Firefox. This will happen during screen drags, during game play of any game.

Current System
Win 10 1803
Ryzen 7 x2700
Geforce GTX1080TI
16GB RAM
Samsung 850 256 GB SSD

Previous system
Win 7
GTX960
16GB RAM
AMD 8330

0 Likes

#2

@Tw0aces,
Thanks for reaching out - and excellent report! Appreciate all the details up front!
It’s a bit hard to see the difference in those gifs but I think I get the idea.

I’m going to wager that it’s a hardware acceleration issue - it seems to be the cause of several issues similar to this one. Can you try disabling Hardware Acceleration and see if that resolves the lag?
Settings --> Advanced --> System --> Hardware Acceleration

0 Likes

#3

I apologize, the GIFs don’t do as much justice I would have liked. I have tried disabling the hardware acceleration, and the issue still persists, even if the video is paused. If I close just the netflix session and still have Brave Browser going the issue disappears.

1 Like

#4

Thanks for the info!
I see that you have multiple monitors set up on your machine. Does this behavior happen when there’s only one monitor?

0 Likes

#5

Hmmm… i have 3 set up… I have never tried without… Give me a few moments and I will test for you.

0 Likes

#6

Going down to my one monitor 2560x1440, the issue disappears.

1 Like

#7

There it is.
Great teamwork!
Not an ideal solution - obviously you should be able to use as many monitors as you want without this issue. It’s unlikely your graphics card “can’t handle it”. Unfortunately it’s both late and the weekend so a more sustainable solution may have to wait until after the weekend.

I will, however, make sure your thread gets seen by the proper eyes. I’ll leave this thread open for now and let you know when I have more information.
cc @sriram on this - seems like something he’d know about.

0 Likes

#8

Thanks,. I really wanted to just report it as a bug, and wasn’t looking for a solution… I am willing to help with what information that is possible. I am SUPER impressed by the support by brave and the response time is amazing. I will continue to use for regular browsing for now and firefox for netflix viewing until the issue is resolved.

1 Like

closed #9

This topic was automatically closed after 30 days. New replies are no longer allowed.

0 Likes