VPN doesn't show up in incognito


I need to sign up on a site, & I need to use a US VPN to do it. How come the VPN button on the top right doesn’t show up in incognito?

I wanted to make 100% sure the site thinks I’m in the US since all of these evil sites (due to the digital prison) won’t let you do anything if you aren’t in the country where your address, credit card, etc. is located.

It’s just terrible.


Enable the VPN in a standard browsing window first, then open the Private browsing window. You can also enable the VPN via the Windows tray.

@Mattches - hey, how are you doing?

Ok, so next question, is there a way to have it work on only one window or tab?

I’m going to assume no, but it’s something I’m sure others probably want as well.


Unfortunately no there is no way to do that — VPN will work across all Brave windows (and across your PC in general).

Oh, you mean it will also control my Thunderbird???

That’s not good. Every time a VPN controls the entire computer, it screws up my TB so that gmail thinks someone is hacking in & then I have to spend 30 minutes logging into every gmail webmail version to tell it that it’s ok, it’s just me, & then TB starts working again.

Proton VPN has a setting that sets it to ONLY work on the browser. I’m surprised yours doesn’t have that option.

Thank gawd you told me this now.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.