Video Playback Keyboard Shortcuts don't work on YouTube

Description of the issue:

I’m using a European (Spain) Spanish keyboard layout on MacOS.

According to the keyboard shortcut list on YouTube Shift+, and Shift+. as well as > and < should increase/decrease playback speed.

However, on Brave only the > for increasing playback speed seems to work while < does nothing. And neither Shift+, or Shift+. work either.

On firefox, at least Shift+, and Shift+. work out of the gate (and I have accidentally managed to make > and < work, but I don’t know how). So I know the keys physically work, they’re not mapped to any other shortcut anywhere on the system and they should work on Youtube.

Changing languages (using US English or Spain Spanish) on Youtube, Firefox or Brave doesn’t seem to change anything. Only changing the keyboard layout to US-English on a system level works, but I don’t want to do that.

The problem persists even on a fresh new profile, without having installed extensions or changed any settings.

The problem also exits on Google Chrome.

Is there a way to make these key combinations work?

How can this issue be reproduced?

  1. Use a European Spanish keyboard layout
  2. Try to use Shift+, and Shift+. as well as > and < to increase or decrease video playback speed.
  3. See if it works

Expected result:

Lower/higher video playback speed.

Brave Version( check About Brave):

Version 1.9.76 Chromium: 81.0.4044.138 (Official Build) (64-bit)

@Engines_Warrior,
Do you have any extensions installed in the browser at this time? I’m wondering if one of them is causing the conflict with the YT player.

On my end, also using macOS on Brave stable, I’m seeing the keyboard shortcuts work as intended. However, simply hitting the > key does not work in either direction – only using Shift + , or Shift + . changes the playback speed.

@Mattches,

I have created a new profile and went straight to YouTube, without installing any extensions or changing any settings and the only shortcut that works is >, which I input by holding down Shift and pressing <. All the other three don’t work.

@Engines_Warrior,
Perhaps I’m confused – the , and . characters are on the same key as the > <

:point_up: So you’re saying that you’re pressing Shift + < and it works for changing playback speed, but the other commands do not? Because there are really only two different commands we’re talking about here:

@Mattches,

As I said above, I’m not using an English layout. I’m using Spanish layout on MacOS.

On my layout the < and > share one physical key. And the , and .are two separate keys.

Something like this: https://upload.wikimedia.org/wikipedia/commons/thumb/7/74/KB_Spanish.svg/2880px-KB_Spanish.svg.png


So you’re saying that you’re pressing Shift + < and it works for changing playback speed, but the other commands do not? Because there are really only two different commands we’re talking about here:

I know that Shift+, and Shift+. don’t work at all. Those are two separate keys that don’t work at all.

Then there’s the one key shared by < and >. And that key only works to increase speed when I press Shift+<.

< alone should decrease speed, but does nothing.

Shift+< on my layout inputs > and increases speed.


Again, the keyboard shortcuts work on Firefox as intended. Shift+, and Shift+. decrease and increase speed respectively. (And in the past, I don’t know what settings I changed or where, < and Shift+< decreased and increased speed [and I had to reset my Firefox settings to get the Shift+, and Shift+. back working).

It is on Chrome, Brave and (now that I’ve checked) Safari, that the shortcuts don’t work. Only the < key while holding Shift (which inputs > on my Spanish layout) work to increase speed on YouTube. Neither Shift+, nor Shift+. work. Nor does the standalone < key without Shift

Now, when I change my Keyboard Layout on my System Preferences to English (US), the Shift+, and Shift+. keyboard shortcuts work as intended on all browsers, but not the < and Shift+< shortcuts, because the physical < key, on the US layout, is a ` and ~ when holding Shift.


The problem is that I would rather not change my keyboard layout, because that would mean relearning how to type. And I couldn’t type in my language comfortably.

Now, if these Shift+, and Shift+. shortcuts didn’t work on any browser at all, I would probably just resent Google for assigning the shortcuts they did and move on. But they do work on Firefox with my Spanish layout. Which makes me think that there should be a way they would work on Brave with the same layout.


Lastly, I don’t know how common this issue might be. Or how many people might just not care because they don’t use speed keyboard shortcuts on YouTube.

But I do know that there’s at least another person in the world with the same issue (only with a German layout):

But, like me, no answers.


To reiterate, it’s not extensions that are making it work or preventing it from working on either browser. I have tried the shortcuts on fresh profiles in both browsers and they work on Firefox but not on Brave.


So, any idea what it might be?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.