Using Uphold disconnects Brave browsers

Briefly describe your issue: Used Uphold to buy some crypto and all my Brave browsers were disconnected

**What Operating System and Brave version are you using (Menu --> About Brave)?**Win 11
Version 1.45.123 Chromium: 107.0.5304.110 (Official Build) (64-bit)

Is your browser wallet currently verified? (yes/no) Yes

What date did you verify your wallet? Reverified about a month ago

Have you been able to successfully receive payments in the past? Yes

Are you using a VPN? (yes/no) No

Are you in a supported region (see here for list of supported regions)? Yes

Does your device pass the SafteyNet check (Android only)? N/A

Have you fully completed Uphold’s CDD requirements? Yes

I used uphold to buy some crypto and it disconnected all the browsers I had connected, Ive put a ticket in with Uphold about this. The problem I’m now having is reconnecting the browsers, I’ve managed to connect 3 browser and the 4 I get an error message

"Error: Brave Rewards profile is flagged
Unfortunately, your Brave Rewards profile has been flagged, and you’re not able to verify with a custodian at this time. This flag can sometimes be due to irregular Brave Ads activity, though it can also be a false positive.

Note that while your Brave Rewards profile is flagged, you won’t be able to verify.

No action is required on your part. Your Brave Rewards profile will be automatically re-evaluated on a regular basis to determine when (or if) the flag can be removed. Please try again every so often to see if the flag has been removed."

If using Uphold in anyway causes your browsers to be disconnected each time and re-connecting them gets you flagged what are we supposed to do?

Thanks

If you’re flagged, that’s from Brave’s side. Not from Uphold. You’ll have to raise a ticket with Brave
Raise one at