Uphold wallet disconnected from verified wallet and now it cant be connected back

tried this nothing happens

can u elaborate the steps for mobile device please

Unfortunately, I cannot recommend a solution for Android

yeah your method works fine for the desktop but for the android i tried logging in on the new uphold website but still the brave wallet shows disconnected

same problem here… i cant connect my verifyed wallet to any profil…

2 Likes

I had the same problem. What worked for me is disabling Brave shields for the page that has the confirmation button. To disable shields, click on the icon next to the brave address bar that looks like a lion’s head. That will open a dropdown that has some sliders. Click the top most slider, and that will disable all shields for that page. After that, reload the page, and then click the confirmation button again. I’m going by memory here, so this may not be 100% correct, but it should be enough to get your wallet verified.

Edit:
Ok, I was able to disconnect my wallet and recreate the process. See the screenshots below:

  1. Click on the uphold wallet button on brave://rewards page:

  2. Click on the button to connect to the Uphold wallet, and it should take you to the following page.

  3. Click on the lion’s head icon next to the address bar.

  4. Click on the top slider to disable shields for that page.

After that, it automatically refreshed the page. Just click on authorize and follow the prompts. Hopefully this is helpful.

8 Likes

Having the same problem. Had to use VPN to be able to trade this afternoon.

this worked for me .
THANKS A LOT

No problem. Glad it helped.

thanks PLINK82… WORKED

Same! I’ve never been able to verify my wallet. Any ideas? It is frustrating!

Thanks! How do you get to that first page (step 1)? When I’m in brave and I click verify, just nothing at all happens. Where is the button to connect to the upload wallet?

See step 1 in my edited post. You have to navigate to the brave rewards page, i.e. enter brave://rewards in the address bar. At the top of the page that shows your wallet balance, there is a button that may or may not be greyed out. Click on it, and that will take you to the page in step 2 (was step 1). If that button is not greyed out, you may need to disconnect your wallet, then try reconnecting.

desactiva la proteccion brave authoriza .

Thanks! Mine isnt greyed out - it says verify wallet but when i click nothing happens. How do you disconnect your wallet?

The only way that I know to disconnect your Uphold wallet is to click on the button that says “Disconnected” in step one. I suppose for you, it would say “Verify Wallet.” When you click on it, a drop down appears that has the option to “Disconnect from Brave Rewards.” Because that button is for the Uphold wallet, it is disconnecting your browser’s BAT wallet from Uphold. Just to be clear, all of this is for the Windows 10 and Linux desktop versions of Brave. It’s a similar procedure for Android, but I don’t own and iOS or macOS devices, so I can’t say what the procedures are there.

this method worked for me. Thanks :slight_smile:

I am having the same issue. I deactivated brave shield, but the problem persist.
My brave version is: 1.26.67 Chromium: 91.0.4472.114

Can anyone help me? thanks!

@c3r34lk1ll3r try the post i made in the link below… this has worked for me multiple times

@tonymend1980 thanks for your response, I’ve tried, but the problem persist :frowning:

1 Like