Update not working

Brave update has not been working for some time now. I am still on version 1.25.72, and when it tries to update I get this:
An error occurred while checking for updates: The download failed. (error code 7: 0x80072F8F – system level).

This issue can easily be reproduced by simply opening “About Brave”…every single time, it bombs. On my home computer, I actually uninstalled/reinstalled to get it working, but that was a lot of effort which I don’t really want to go through on my work computer.

As I mentioned, my current version is 1.25.72.

I tried running as Administrator, but I get the same error.
Running on Win7.

Does this help? I can't download BRAVE! - #27 by JimB1

Thanks for the help Jim, I deleted the certificate in question and am about to try again…I’ll let you know how it goes.

Nope, same results :frowning:

Can you try simply re-downloading and re-running the installer for the browser and see if this allows you to at least update to the latest version? Note that running the installer will not overwrite any data, it will only fetch/apply the latest updates if a current installation is detected on your system.

1 Like

Just to clarify – there also needs to be the addition (installation) of an updated root certificate. Did you do that step as well?

I did not do that! Right now I’m trying re-running the installer without deleting my old installation…if that fails, I’ll go back and re-read the certificate instructions…

1 Like

That did it! Thanks for that…I am now at 1.32.113 :grinning:


Thanks for your help, Jim…but now I’m all updated just by re-running the install without deleting my prior installation.


Very glad to hear that worked.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.