Unresolved: brave remembers desktop and window position

Description of the issue:

Windows 10 allows multiple desktops.

When the browser is restarted, it remembers which desktop it was on previously.



How can this issue be reproduced?

  1. Use Brave
  2. Close Brave
  3. Restart Brave

Expected result:
This is probably the expected behaviour.

**Brave Version( check About Brave):
Version 1.51.118 Chromium: 113.0.5672.126 (Official Build) (64-bit)

Additional Information:
Is there a setting which controls this behaviour and which allows it to be changed?

Hi there, welcome to Community :wave:

Just so that I understand clearly, Brave is opening on the same Desktop session rather than opening up on the active Desktop session you are using?

Do you experience this with other programs or browsers as well?

This is happening for me as well and it is only with Brave Browser when I fit the window positioning to the screen like snapping the window to top and bottom or to the left or right side not in full screen after closing and opening the app again it is no longer snapped and connect to the edges of the screen where I previously had placed them there is a little bit of space in between the edges of the screen and the brave window on the sides and the bottom but the top is fine and right up against the end of the monitor which is how it should fit perfectly but it always does this. I’ve uninstalled and reinstalled none of that helped its the only app or web browser that is doing this which is why it is so weird and think that it has to be a bug or what the person up above is talking about

Hi @Joluto

Thanks for sharing. Do you mind if you share a screen recording or screenshot of the issue you are experiencing?

this is when window is full top and bottom to screen and next one will be after closing the app and opening it again

This next one will be snapped in window to the side

This is normal on the side now I will close the window and reopen it

I downloaded an Extension to Chrome, Microsoft Edge, and Brave Browser called Window Resizer the Grey square and yellow Icon one and on chrome and microsoftedge when in maximized mode it shows the right aspect ration 43:18 and 3440x1440 resolution but in brave browser its saying aspect ration 689:276 and the resolution reads 3445x1380 so I found somewhat the problem but I still don’t know how to fix this. Is there a fix that I can do on my end? Or is it a bug with the latest update? Using this extension does not fix the problem either. I’ve tried so much to fix this and I’m not 100% sure if all my pc hardware and software components are all up to date but its not happening for any other browser or application so its really weird that this happened I think after I did fresh windows reset on my pc

Hi @Joluto

Thanks for sharing those screenshots, it does illustrate better what your issue is.
It is strange that the window does not snap to the edges.
Unfortunately, I am unable to replicate this specific issue. What is your device OS version and Brave browser version?

My friend tested it out as well and he has the same problem but it’s did not do this before for him either
My OS BUILD is 19045.3031
And brave is Version 1.52.117 Chromium 114.0.5735.90

Thanks @Joluto for sharing. I passed your issue along to our team to review.
Do you have any management programs installed that helps to organize your browser windows or the like? Similarly, are there any specific configurations you have in your settings that could be causing this issue i.e. have you tried changing the orientation of your task bar to see if you can replicate the issue?

@DeezNutz following up if you require any additional assistance?

I don’t have any other programs or settings changed the only thing I do is put the taskbar to the right side I’ve always used my taskbar on the right with no problems and auto hide the taskbar but I’ve tried all positions with auto hide on and off and same problem with the browser and only brave I had fresh installed windows about 4 or 5 times trying to fix the problem but nothing and so it would even happen when all settings were completely at default and everything is up to date

This morning I noticed that it’s doing it for chrome and Firefox now too but not on Microsoft edge

Hi @Joluto

Apologies for the delay. Just confirming, are you experiencing this issue on windows 10?
It could possibly be caused by mismatched resolution/scaling on your monitor or possibly a driver issue?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.