Re-opening/rebooting: Brave does not remember previous windows size and location

bug
performance
#1

Description of the issue:
Re-opening/rebooting: Brave does not remember previous windows size and location: whenever i turn off my pc at night, i expect that the next morning, when i turn on the pc again, that the several Brave browsers remember where i had positioned them to reopen at the same locations with the last pages still on them. well, the brave browser does indeed remember my tabs, but more often than not, the brave browser will flash and try to open for maybe 1/3rd of a second, that’s estimating it at 0.3 seconds. Then, all signs of Brave disappear.

when i re-click the brave icon in my quick launch bar to reopen the brave browser, of course, all the tabs are now lost and i have to open up several brave browsers and carefully re-position them again. this is a real hassle every single morning, essentially. i’d say 3 to 4 times out of 5, this malfunction happens.

Steps to Reproduce (add as many as necessary): 1. 2. 3.
the only way to reproduce this is to reboot the pc many times and do a tally on how often it happens. but for me, thus far, it’s roughly 3-4 times out of every 5 reboots.

Actual Result (gifs and screenshots are welcome!):
can’t do a screenshot as the brave browsers would struggle to open for merely 0.3 seconds (approximately), then completely disappear.

Expected result:
i would naturally expect at each reboot, that all my brave windows would reopen at the same sizes and locations.

Reproduces how often:
3-4 times out of every 5 reboots.

Brave Version(See the About Brave page in the main menu):
Version 0.61.51 Chromium: 73.0.3683.75 (Official Build) (64-bit)

Reproducible on current live release (yes/no):
Yes

Additional Information:

0 Likes

#2

@Dualmonitors,
Do you have Brave set to restore tabs that were previously open when it first starts?

0 Likes

#3

@Mattches: thanks for your reply.

yes, i checked the first check box under Start up in the Options page:

“Restore Previous Session”

may i ask if there’s anything else that i might be able to do?

most often, ALL the browser windows (usually 3 or 4) would barely open up or struggle to open up for less than 1 second, maybe 1/3rd of a second, like a flash, and before they can even fully open, literally like a flash, they close down and there’s no more Brave on the screen. At that point, i have to click Brave on the quick launch area again and have to open 3 or 4 of them and reposition them - it’s a hassle every morning. something tells me this ought not be the way it is expected to perform, right?

thank you again and look forward to hearing more. thx.

0 Likes

#4

Can you try disabling Hardware Acceleration? I’m not convinced this is the issue but it’s very easy to test and could potentially resolve all of this. To test, navigate to
Settings --> Advanced --> System --> Hardware Acceleration

Let me know if this works for you.

0 Likes

#5

thanks for your detailed instructions.

i just went to exactly that area of settings and used the sliding on/off to turn off:

“Use hardware acceleration when available”

i’ll report back after 1-2 days as i only turn my pc on typically in the mornings and leave it on the whole day until around 11pm at night.

thank you.

1 Like

closed #6

This topic was automatically closed after 30 days. New replies are no longer allowed.

0 Likes