Unable to view site This site can’t provide a secure connection, *** uses an unsupported protocol

Recently I have not been able to access the official web mail of the company.

This site can’t provide a secure connection

**********.rs uses an unsupported protocol.
ERR_SSL_VERSION_OR_CIPHER_MISMATCH
Unsupported protocol
The client and server don’t support a common SSL protocol version or cipher suite.

I took Shields down, it didn’t help.

Until a few days ago, everything worked, now it doesn’t.

I cannot influence the security configuration of that website and its security protocols.

How do I overcome this problem?

Version 1.35.100 Chromium: 98.0.4758.87 (Official Build) (64-bit)
Windows 10 Pro

Google Chrome has no problem accessing this page.

I had to downgrade to version 1.34.81. Now it works again.

Update Chrome has made it a problem that this site also doesn’t work on its latest version.

gvlada,

May interest you:

And over on the right, “Test Your Browser” - do that.

I am using Brave Browser version 1.35.100 for Mac OS.

Probably, the results that you get, should be similar to my BB’s test results – so that you understand, your Brave Browser has a common SSL protocol version and cipher suite:

1 Like

Thanks for the comment, but unfortunately none of these SSL/TLS test results does not help to solve the problem

I have the same problem just looking at an internal IP.

@gvlada , @fakeologist ,

What may work (instructions for Windows OS and Mac OS users):

While running Brave Browser, close all tabs / windows, and then delete as much of the cache, data, and history as you believe that you can.

Next, quit everything. After that, then:

Move the CONTENTS ONLY of the following “CertificateRevocation” folder to the Trash:

%LOCALAPPDATA%\BraveSoftware\Brave-Browser\User Data\CertificateRevocation

aka

C:\Users[UserName]\AppData\Local\BraveSoftware\Brave-Browser\User Data\CertificateRevocation

Mac OS:

/Users/user_username/Library/Application Support/BraveSoftware/Brave-Browser/CertificateRevocation

Restart your computer. After your computer settles down, start Brave Browser and test.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.