Unable to Sync iPhone with new Mac


**Description of the issue: Currently operating latest version of Brave on iOS 15.6. Recently purchased a new Mac & installed Brave. Tried to create a sync chain, but receive error “This code was generated by a deprecated version of Brave, please upgrade your other device first.” Both devices are running latest version. Cannot move past this screen.

**How can this issue be reproduced? Enter the system-generated sync code.

**Expected result: Same error occurs every time.

**Brave Version( check About Brave): 1.41.1

Additional Information:

1 Like

Has anyone had any success with a work-around or fix for this issue? I was hoping the latest update to Brave would take care of it, but I am still having the same problem.

Tagging @ Mattches & @jsecretan since they seem to be tracking this sort of issue.

@ Saoiray Help please?
Any ideas on how to rectify this? Much appreciated!

@SonjaJ Sync code has been 25 words for a while now. If yours is 24 words, it means yours is far outdated. If yours is 25 words, it’s important to note that the 25 word code actually changes daily, so you can’t keep it as a backup.

Good news is just the 25th word is what changes, at least for now. So typically for someone like you, can just add or replace the 25th word. One of the devs created a site where you can check the 25th word, which you just need to add/replace to the end of your phrase. Link to site is https://alexeybarabash.github.io/25th-brave-sync-word/

Todays’ word, if you want to hurry and add it, is aware

As to sync, keep in mind their warning.

Warning: Brave does not officially support using the Sync code as a backup and you should not rely on this continuing to work in to the future. Use the export functionality in bookmarks and the password manager instead.

1 Like

@Saoiray , thank you so much for your help. I’ve tried getting a new code on my phone to add the new desktop device and it keeps giving me the same code.

I’m using brave version Version 1.42 (22.8.15.22) on my phone & am not being prompted to update. Am I doing something wrong?

Thank you again for your help!!