Unable to reconnect Brave to Uphold

Troubleshooting technical issues is much easier when both the user and support agent practice clear communication. For this reason, we have provided the template below for you to fill out with information about your issue. Please provide as much detail as possible so we can most efficiently resolve your problem.


Description of the issue: I’m trying to reconnect my Uphold account on Brave Mobile. When I hit the disconnected button it navigates to a page to authorize. I click authorize. Then it goes to an Uphold account creation page. I click login at the top and enter my info correctly. I then enter my 2fa code correctly. Then Uphold sends me an email to confirm I was the one logging in. I confirm. I am then taken to Uphold successfully logged in however my wallet still isn’t connected to Brave. In my linked accounts on Uphold I can see Brave as approved. But in brave I am disconnected.

How can this issue be reproduced?

  1. Click Brave Rewards button in address bar.
  2. Click disconnected to reauthorize Uphold wallet. Authorize and login with email, and pw, then 2fa.
  3. Confirm email that it was me that logged in.

Expected result: Successfully reconnect Uphold.

Brave Version( check About Brave): Brave 1.24.84, Chromium 90.0.4430.93

Mobile Device details Google Pixel 2

Additional Information:

If you force close brave then restart brave, does it correctly show wallet verified with uphold totals?

I force closed it and restarted as you suggested. I’m still having the issue unfortunately.

You aren’t seeing an error message in brave saying you’re over your device limit? Are you over you’re device limit - 4 brave instances verified to uphold already?

Not seeing that error. My mobile is 1 of only 2 devices I use Brave on.

The only thing I can think of now, is to verify wallet, when you get directed to uphold’s site, click the lion head head icon in the address bar, disable shields for now… the browser will reload the uphold page… Go through the verification and hopefully it works…

2 Likes

That worked. Thank you so much for responding quickly and for your help!

1 Like

So go back to uphold’s website and fix the shields settings… Re-enable shield and I think you just need to allow all cookies for block 3rd party cookies… If you don’t see the individual shield settings, there should be an advanced link that you need to click… Earlier i had you just turn off shields because it’s faster for fixing your issue…

1 Like

Alright I re-enabled it thanks again!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.