Theme does not reset

Description of the issue:
My browser theme does not reset back to default. I installed “Dark Theme for Google Chrome”, it turned everything dark, to the point where Wikipedia is not readable anymore.
I have tried resetting theme and resetting all settings, it has not solved the issue.
Setting Brave to light mode does not help either.
I’ve tried installing other themes but they don’t help either.

How can this issue be reproduced?

  1. Install Dark Theme for Google Chrome

  2. Go to wikipedia and realise it’s unreadable

  3. Try to reset theme and settings, nothing changes

Brave Version( check About Brave):
1.25.7

Additional Information:
help me everything is dark

Hey Frazic,

When you say you reset your settings, you mean that you went to brave://settings/reset, correct? I’d just like to make sure.

Also, can you confirm that you have this issue in Google Chrome as well?

Hi Adrian,

To reset the theme I went to Settings > Appearance > Theme > Reset to default
To reset my settings I went to SEttings > Additional settings > Reset settings > Restore settings to their original defaults

I’ve tried installing it on Chrome but the theme doesn’t seem to work. I’ve installed it but nothing has gone dark so I’m not quite sure what’s going on

Strange. I installed the theme myself, but I haven’t had the issue that you’ve posted about.

Before I suggest anything drastic, do you have any extensions? If so, turn them off and see if that changes anything. If not, get back to me.

I’ve turned off extensions, tried downloading a new theme, no change
I then hit reset to default, still nothing

What’s the next step ? :smiley:

I’d recommend that you reinstall Brave, then. Do not uninstall Brave, lest you want to lose your data. Instead, delete the old installer, then download and run a new one.

T_T

I’ve deleted the installers, downloaded a new one, reinstalled and everything is still dark.

What have I brought upon myself

Hi @Frazic,
Can you test a new private window to see if there are still issues with the theme?
Can you also try creating a new test profile and see if there are still issues?

Hi Aa-ron,

I’ve done both suggested things and the issue still persists.
A strange part of this issue that I’ve noticed, and it may or may not help : this is in google sheets, the colour “light yellow” among others is super dark.
image

Can I get a confirmation that google chrome has no colour issues on any site (including google sheets)?

Can you send a screenshot of the appearance page in settings (brave://settings/appearance)?

Can confirm, google chrome is fine everywhere, including sheets :
image

Here is my appearance page :

Can you try going back to the chrome web store, installing a random theme. Once installed you should see a prompt at the top to ‘undo’, please click the undo prompt and see if it reset your Brave theme to normal.

A good idea, tried it but my browser is still very much the same dark :c

Try again, but instead of undo, go into settings and click reset theme.
If that doesn’t work,
Can you try resetting settings via brave://settings/reset.

could you have installed the turn off the lights browser extension by mistake, along with the theme, the extension makes everything on pages dark?

That’s actually a good suggestion.
Is there any other place the extensions could be installed but here ?

Hey, I’ve just done both of those things, still nothing new :confused:

Hi @Frazic,
So themes are installed in the extensions folder. Even when you disable a theme it’s not removed.
Can you try going into this folder and deleting the theme from there?
path:
C:\Users\YOURNAME\AppData\Local\BraveSoftware\Brave-Browser\User Data\Default\Extensions

The folder names make it hard to tell what each extension is.
You’ll have to open each one and see if there are any files with theme in the name. If so, you can prob delete the entire folder.
You could also delete all folders but that means you’ll have to reinstall extensions.