The translator doesn't automatically translate

The translator doesn’t automatically translate now, it used to but not now, I use it all the time for Spanish to English.

Hello @ruffneck247, thank you for reaching us out. What kind of device and OS do you use? Have you updated to the most recent Brave version? Are you getting any error while pressing the translate button? Please let us know this information so we can further investigate. Regards.

I have both an android phone and a windows 11 pc, it doesn’t work on either.

I have the same problem, the translator does not show the option “always translate into English” on my desktop and my android device and every page I visit in a foreign language I have to click on the Spanish icon and it does not translate automatically

traductor

It is still not working and very often the translator doesn’t work.

Brave Team Disabled it:

but they never added the flag to enable it or control it, and they never added the option to do it from the UI like it seems they would have done based on this:

Anyway, you can enable it back if you start brave with --enable-features=BraveEnableAutoTranslate

But for example, they roll features with ‘variations’ and example, my brave://version will say BraveAutoTranslateStudy:AutoTranslateDisabled

and not much to do, it is mean to be this way, for now, at least.

Anyway, there is a flag chrome://flags/#desktop-detailed-language-settings where you can get a better UI for brave://settings/languages it has the way to add languages to automatically translate but doesn’t work, so not much to do but wait.

About Translate failing sometimes, well, it is not perfect and also some pages fail if you don’t enable this flag on both Desktop and Android.
chrome://flags/#enable-translate-sub-frames

There is also a Flag in Android to change the Translation UI so it is a popup and not a bar on the bottom, if you are interested in that one.

1 Like