Tabs slow to open in macOS

Description of the issue: when opening a new tab, there is painful lag for several seconds before I can input anything in the search field

Steps to Reproduce (add as many as necessary): 1. 2. 3. 1. open new tab. 2. Tab hangs with macOS infamous pinwheel/beach ball running as I wait.

Actual Result (gifs and screenshots are welcome!):


Expected result: I expect a new tab to load like on my Windows 10 workstation in less than one second.

Reproduces how often: Every time I launch a new tab

Brave Version(about:brave): Version 1.1.23 Chromium: 79.0.3945.88 (Official Build) (64-bit)

Reproducible on current live release (yes/no): YES

Additional Information: I have deleted the Preference List, and the BraveSoftware support folder in ~/library/application support/ as per support article per I restarted my system, then reinstalled a fresh copy of Brave. Tabs were opening fine until about the fifth one I opened then the problem resumed. Tab lags for several seconds before one can input anything in the search field. Then works fine and is as fast as on any device.

I thought it may be the Google Translate extension I use. So I deleted and restarted, but the problem continues without it.

I am running macOS High Sierra 10.13.6. My MacBook Air can’t be upgraded to a later OS beyond that. This is the only issue and system I have an issue with Brave on. I use it with no problem on an iPad 4, iPhone 7, and work Windows 10 desktop.

I saw some threads speaking to this issue, but saw no resolution.

Thanks @neverman for reporting. Can you tried toggling off hardware acceleration in settings?

1 Like

Thank you, I did, relaunched and tested opening a couple of tabs which did in a jiffy. Then opened another, and problem resumed. I checked to make sure Hardware Acceleration was disabled, and it was.

If I open a link in a new tab, it does instantly no problem. It’s only when I open a fresh new tab that I experience this problem. The new tab looks like this for several seconds:

Here’s also a screenshot of the tab page source:


I timed it here. It was 31 seconds before the cursor populated allowing me to search on a new tab. Note I disabled all the active elements and background default Brave background photo trying isolate any of that out as a possible cause.

Please let me know if there’s anything you’d like to see from the inspector I can capture for you.

Hi @neverman - I’m sorry for the delay. Do you have a sync chain enabled by chance?

Hello. Thank you it’s no problem. No, I currently don’t have a sync established or enabled. I think I did with the first installation, but not since.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.